Bug 866199 - 'nova hypervisor-uptime <id>' fails with exception
'nova hypervisor-uptime <id>' fails with exception
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: beta
: 3.0
Assigned To: Nikola Dipanov
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 12:05 EDT by Yaniv Kaul
Modified: 2016-04-22 01:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-nova-2013.1-3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 11:27:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1039628 None None None 2012-10-14 12:07:39 EDT
OpenStack gerrit 21716 None None None Never

  None (edit)
Description Yaniv Kaul 2012-10-14 12:05:47 EDT
Description of problem:
[ykaul@ykaul ovirt-engine]$ nova hypervisor-uptime 1
ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-3d36268d-b938-474e-807d-a6de423d1766)

See additional information for exception from /var/log/nova/compute.log.

Version-Release number of selected component (if applicable):
[ykaul@ykaul ~]$ rpm -qa |grep nova
openstack-nova-api-2012.2-1.fc18.noarch
openstack-nova-network-2012.2-1.fc18.noarch
openstack-nova-2012.2-1.fc18.noarch
openstack-nova-volume-2012.2-1.fc18.noarch
openstack-nova-objectstore-2012.2-1.fc18.noarch
python-novaclient-2.9.0-1.fc18.noarch
openstack-nova-cert-2012.2-1.fc18.noarch
python-nova-2012.2-1.fc18.noarch
openstack-nova-console-2012.2-1.fc18.noarch
openstack-nova-scheduler-2012.2-1.fc18.noarch
openstack-nova-compute-2012.2-1.fc18.noarch
openstack-nova-common-2012.2-1.fc18.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:2012-10-14 18:03:20 ERROR nova.openstack.common.rpc.amqp [-] Exception during message handling
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp Traceback (most recent call last):
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.7/site-packages/nova/openstack/common/rpc/amqp.py", line 275, in _process_data
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp     rval = self.proxy.dispatch(ctxt, version, method, **args)
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.7/site-packages/nova/openstack/common/rpc/dispatcher.py", line 145, in dispatch
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp     return getattr(proxyobj, method)(ctxt, **kwargs)
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.7/site-packages/nova/exception.py", line 117, in wrapped
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp     temp_level, payload)
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp     self.gen.next()
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp   File "/usr/lib/python2.7/site-packages/nova/exception.py", line 92, in wrapped
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp     return f(*args, **kw)
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp TypeError: get_host_uptime() takes exactly 3 arguments (2 given)
2012-10-14 18:03:20 TRACE nova.openstack.common.rpc.amqp 
2012-10-14 18:03:20 ERROR nova.openstack.common.rpc.common [-] Returning exception get_host_uptime() takes exactly 3 arguments (2 given) to caller
2012-10-14 18:03:20 ERROR nova.openstack.common.rpc.common [-] ['Traceback (most recent call last):\n', '  File "/usr/lib/python2.7/site-packages/nova/openstack/common/rpc/amqp.py", line 275, in _process_data\n    rval = self.proxy.dispatch(ctxt, version, method, **args)\n', '  File "/usr/lib/python2.7/site-packages/nova/openstack/common/rpc/dispatcher.py", line 145, in dispatch\n    return getattr(proxyobj, method)(ctxt, **kwargs)\n', '  File "/usr/lib/python2.7/site-packages/nova/exception.py", line 117, in wrapped\n    temp_level, payload)\n', '  File "/usr/lib64/python2.7/contextlib.py", line 24, in __exit__\n    self.gen.next()\n', '  File "/usr/lib/python2.7/site-packages/nova/exception.py", line 92, in wrapped\n    return f(*args, **kw)\n', 'TypeError: get_host_uptime() takes exactly 3 arguments (2 given)\n']
Comment 2 Nikola Dipanov 2012-12-13 06:32:47 EST
There seems to be a patch proposed upstream however it seems to be abandoned by the author. https://review.openstack.org/#/c/11722/

I don't see this as important enought to backport but should be fixed definitely so I will
Comment 3 Martin Magr 2013-02-27 09:26:27 EST
Fix for this has been merged upstream https://review.openstack.org/#/c/21716/
Comment 4 Nikola Dipanov 2013-05-30 11:27:58 EDT
The fix mentioned in comment #2 is part of the grizzly upstream release so will be automatically included in RHOS 3.0.

Note You need to log in before you can comment on or make changes to this bug.