Bug 866404 - [HCK][SVVP]Boot From USB(ServerOperation System) job failed on win 2012
[HCK][SVVP]Boot From USB(ServerOperation System) job failed on win 2012
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: TestBlocker
: 866405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 05:42 EDT by Mike Cao
Modified: 2012-11-01 22:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 22:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-10-15 05:42:57 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kernel-2.6.32-301.el6
qemu-kvm-0.12.1.2-2.307.el6
windows server 2012 guests


How reproducible:
100%

Steps to Reproduce:
1.Start Guest with UFD
/usr/libexec/qemu-kvm -m 16G -smp 8 -cpu Nehalem,+x2apic,family=0xf -usb -device usb-tablet -drive file=win2012-64-sut.raw,format=raw,if=none,id=drive-ide0,cache=none,werror=stop,rerror=stop -device ide-drive,drive=drive-ide0,id=ide-drive0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:52:43:75:51:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid a19b1188-7550-448b-908b-75980afea207 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/sut-2012,server,nowait -mon chardev=111a,mode=readline -name win2k8-R2-sut -vnc :2 -drive file=en_windows_server_2012_x64_dvd_915478.iso,media=cdrom,id=cdrom,if=none -device ide-drive,drive=cdrom -monitor unix:/tmp/tt_w2012,server,nowait -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:52:00:43:51:01,bus=pci.0,addr=0x9,id=virtio-net-pci1 -device piix3-usb-uhci,id=usb-uhci0 -drive file=usb.img,format=raw,if=none,werror=stop,rerror=stop,id=usb -device usb-storage,drive=usb,bus=usb-uhci0.0,removable=on,serial=1234-123-232,create_unique_serial=1
2.Run job Boot From USB(ServerOperation System)
3.
  
Actual results:
job failed 

Expected results:
job pass

Additional info:

job logs:
2852 1344 2012:10:15 9:12:28:436 Machine: Build=9200.00    Platform=AMD64    OS=Windows Server 2012 Datacenter    ServicePack=""    Version=6.2    BuildLab="win8_rtm"    BuildDate=120725-1247    Language=English (US) (REDMOND)    Config=n/a     
2852 1344 2012:10:15 9:12:28:436 ************* Windows To Go WLK Host Test Log - Stage 1 *************    
2852 1344 2012:10:15 9:12:28:436  INFO: Looking for UFD...  
2852 1344 2012:10:15 9:12:35:61  INFO: Found UFD: QEMU QEMU HARDDISK USB Device  
2852 1344 2012:10:15 9:12:35:61  INFO: Creating partitions and formatting UFD...  
2852 1344 2012:10:15 9:12:38:671  INFO: UFD cleaned successfully.  
2852 1344 2012:10:15 9:12:38:858  INFO: UFD boot partition created successfully.  
2852 1344 2012:10:15 9:12:48:780  INFO: UFD boot partition formatted successfully.  
2852 1344 2012:10:15 9:12:49:139  INFO: UFD boot partition is assigned the drive letter=[F].  
2852 1344 2012:10:15 9:12:49:983  INFO: System firmware type is: BIOS.  
2852 1344 2012:10:15 9:12:49:983  INFO: Provisioning UFD...This can take a few minutes to complete.  
2852 1344 2012:10:15 9:15:1:217 Architecture obtained successfully. Architecture is: x9  
2852 1344 2012:10:15 9:19:22:202  INFO: Ran Windows To Go System Logo host test - Stage 1 with result: _PASS   
2852 1344 2012:10:15 9:19:22:217 Summary: Total=0, Passed=0, Failed=0, Blocked=0, Warned=0, Skipped=0  
2104 1060 2012:10:15 9:22:27:946 Machine: Build=9200.00    Platform=AMD64    OS=Windows Server 2012 Datacenter    ServicePack=""    Version=6.2    BuildLab="win8_rtm"    BuildDate=120725-1247    Language=English (US) (REDMOND)    Config=n/a     
2104 1060 2012:10:15 9:22:27:946 ************* Windows To Go WLK Host Test Log - Stage 2 *************    
2104 1060 2012:10:15 9:22:27:946  INFO: Looking for UFD...  
2104 1060 2012:10:15 9:22:33:931  INFO: Found UFD: QEMU QEMU HARDDISK USB Device  
2104 1060 2012:10:15 9:22:34:744  INFO: System firmware type is: BIOS.  
2104 1060 2012:10:15 9:22:35:213  ERROR: Did not find successful UFD test log: PWSYSTEMLOGO_UFD_LOG_PASS.TXT!  
2104 1060 2012:10:15 9:22:35:213  ERROR: Did not find UFD failure test log: PWSYSTEMLOGO_UFD_LOG_FAIL.TXT!  
2104 1060 2012:10:15 9:22:35:213   ERROR: Test failed due to one of below reasons:  
2104 1060 2012:10:15 9:22:35:213  ERROR: 1) UFD.EXE didn't run due to a BIOS/UEFI  
2104 1060 2012:10:15 9:22:35:213  ERROR:    boot issue.  
2104 1060 2012:10:15 9:22:35:213  ERROR: 2) UFD.EXE's InitializeCom() failed  
2104 1060 2012:10:15 9:22:35:213  ERROR: 3) UFD.EXE's formatting of UFD failed  
2104 1060 2012:10:15 9:22:35:213  ERROR: 4) UFD.EXE's creation of UFD log failed  
2104 1060 2012:10:15 9:22:35:213  INFO: Creating partitions and formatting UFD...  
2104 1060 2012:10:15 9:22:38:526  INFO: UFD cleaned successfully.  
2104 1060 2012:10:15 9:22:38:714  INFO: UFD boot partition created successfully.  
2104 1060 2012:10:15 9:24:36:351  INFO: UFD boot partition formatted successfully.  
2104 1060 2012:10:15 9:24:38:836  INFO: UFD boot partition is assigned the drive letter=[E].  
2104 1060 2012:10:15 9:24:38:836  INFO: Ran Windows To Go System Logo host test - Stage 2 with result: _FAIL   
2104 1060 2012:10:15 9:24:38:852 Summary: Total=0, Passed=0, Failed=0, Blocked=0, Warned=0, Skipped=0
Comment 2 Mike Cao 2012-10-15 06:33:52 EDT
*** Bug 866405 has been marked as a duplicate of this bug. ***
Comment 8 Mike Cao 2012-11-01 22:38:10 EDT
Feedback from MSFT:

you opened the case to address a failure in the Boot from USB test when run on a Virtual Machine. Since you are pursuing SVVP certification and must run on a VM, we confirmed the test is not appropriate and granted HCK Manual Errata ID 1185 to cover the test. 
The current date is 12/1/2013, but that date is somewhat arbitrary. If we fix the issue before then, it may be retired early. Otherwise we will review and extend as needed.

Since this is a manual errata ,QE can not verified it until do submission to MSFT.

Close this bug

Note You need to log in before you can comment on or make changes to this bug.