Bug 866431 - HP 5610 USB printer pauses / stops while printing for long periods of time
HP 5610 USB printer pauses / stops while printing for long periods of time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 07:03 EDT by Brent R Brian
Modified: 2012-12-12 08:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 07:00:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from system-config-printer -> help -> troubleshoot (413.65 KB, text/plain)
2012-12-11 22:04 EST, Brent R Brian
no flags Details

  None (edit)
Description Brent R Brian 2012-10-15 07:03:45 EDT
Description of problem:

Shortly after the last round of updates an HP 5610 USB printer began pausing during print ... every "line printed" ... 5 - 10 seconds some times.  

Samsung ML1710 is fine (USB via ETHERNET).

How reproducible:

Every time I print
Comment 1 Tim Waugh 2012-10-15 08:26:26 EDT
What does 'grep ^.Nick /etc/cups/ppd/*.ppd' say, in a terminal window?
Comment 2 Brent R Brian 2012-10-15 19:47:24 EDT
/etc/cups/ppd/HP-Officejet-5600-series.ppd:*NickName: "HP Officejet 5600 Series, hpcups 3.12.9"

/etc/cups/ppd/Samsung-ML-1710.ppd:*NickName:      "Samsung ML-1710 Foomatic/gdi"
Comment 3 Tim Waugh 2012-10-17 06:56:43 EDT
Thanks. What does 'rpm -q hplip' say?
Comment 4 Brent R Brian 2012-10-17 19:20:34 EDT
hplip-3.12.9-6.fc17.x86_64
Comment 5 Brent R Brian 2012-10-17 19:25:27 EDT
I am wondering if the printer is the problem.

I make a "scan/copy" and it was is behaving oddly.

I did a "hard reset" (pull power and usb).

I printed a single page document, it did well.

I printed a second copy of the same document, it started acting up.

May need another printer ...
Comment 6 Jiri Popelka 2012-11-27 10:09:53 EST
Since it's a USB printer there's a little chance the culprit could be the cups usb backend. Can you follow the instructions in description of bug #873123 ?
You can reply in this bug.
Comment 7 Brent R Brian 2012-12-08 11:33:46 EST
Sorry for the delay ... 

Try to print "test page", minutes go by ...

** lpstat -p 

printer HP-5600 now printing HP-5600-122.  enabled since Sat 08 Dec 2012 09:57:35 AM EST Unable to send data to printer.

** I disabled the printer, lpstat:

printer HP-5600 disabled since Sat 08 Dec 2012 10:45:44 AM EST - Paused

** I enabled the printer, lpstat:

printer HP-5600 now printing HP-5600-122.  enabled since Sat 08 Dec 2012 10:46:36 AM EST Sending data to printer.

printer starts running ... long pauses still ...

** disable
** lpadmin -p HP-5600 -o usb-unidir-default=true
** cycle power on printer
** enable

it restarts the test page ... long pauses

** disable
** lpadmin -p <printer> -R usb-unidir-default
** lpadmin -p <printer> -o usb-no-reattach-default=true
** cycle power on printer
** enable

it restarts the test page .. prints it all, non-stop, except the very last line.  I even get the notice it is finished.  Try another ... same thing, long delays.

** disable
** lpadmin -p <printer> -o usb-no-reattach-default=true
** lpadmin -p <printer> -o usb-unidir-default=true
** cycle power
** enable 

Still Long delays

The "no-reattach" seems to eliminate all the "extra removed" messages in dmesg (execpt for the ones at the power cycling).

I am using the "USB" driver instead of the HPLIP driver ... ???
Comment 8 Jiri Popelka 2012-12-10 07:26:09 EST
(In reply to comment #7)
> I am using the "USB" driver instead of the HPLIP driver ... ???

Well, no, you are most likely using hp backend, so the previous test was useless. I hadn't realized that, sorry :(

Could you attach an output from printing troubleshooter ?
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter


(In reply to comment #5)
> I printed a single page document, it did well.
> I printed a second copy of the same document, it started acting up.
> May need another printer ...

That's another possibility.
Comment 9 Brent R Brian 2012-12-11 22:04:36 EST
Created attachment 661926 [details]
output from system-config-printer -> help -> troubleshoot

This was a "test page".

I ran a "cal 2000 | lpr -P XXXXX" and it took 10 minutes to print the top 10 lines.
Comment 10 Brent R Brian 2012-12-12 07:00:08 EST
Please forgive this horrid waste of your time.

The printer gave NO INDICATION of any error.

I noticed when making a copy, that it was SLOW TOO.  I unplugged it from computer, power cycled printer, tried to copy with USB unplugged, copy still slow.

So, I:

  * replaced black cartridge with spare
  * did alignment
  * slow as blazes

then:

  * ran "cartridge clean"
  * slow as blazes

then:

  * removed the COLOR cartridge and returned it
  * printed a "test page" from the HP 5610's control panel
  * the damn thing worked fine.

The color cartridge was not low, all colors on test page printed fine.
Comment 11 Jiri Popelka 2012-12-12 08:04:39 EST
No problem.

Just FYI, the log in comment #9 has shown that you really use usb backend so the test in comment #7 was worth the try.

'I [11/Dec/2012:21:14:20 -0500] [Job 159] Started backend /usr/lib/cups/backend/usb (PID 2438)',
'D [11/Dec/2012:21:14:20 -0500] [Job 159] Printing on printer with URI: usb://HP/Officejet%205600%20series?serial=CN5AODF3PD04CY&interface=1',

Note You need to log in before you can comment on or make changes to this bug.