Bug 866445 - In WebUI could not add product to changest unless it have repository
In WebUI could not add product to changest unless it have repository
Status: CLOSED NOTABUG
Product: Katello
Classification: Community
Component: WebUI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 07:44 EDT by Miroslav Suchý
Modified: 2012-11-07 11:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 11:27:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2012-10-15 07:44:31 EDT
Description of problem:
In WebUI could not add product to changest unless it have repository.

Version-Release number of selected component (if applicable):
katello-1.1.14-1.git.7.a19ce6f.el6.noarch

How reproducible:


Steps to Reproduce:
1. kk provider create --org ACME_Corporation --name provider1
2. kk product create --org ACME_Corporation --provider provider1 --name product1
3. kk environment create  --org ACME_Corporation --name env1 --prior Library
4. kk changeset create --org ACME_Corporation --name change1 --environment env1
5. Now go to webui in Changeset Management -> Library -> Click on product on left panel

Actual results:
it shows no products there, it will show there if you add repository to this product

Expected results:
product should appear there even without repository assigned
Comment 1 Mike McCune 2012-11-07 11:27:09 EST
this is because we don't show products in the WebUI that don't have any repositories.  There is no point to promoting products that don't contain a repository.

Note You need to log in before you can comment on or make changes to this bug.