Bug 866456 - gluster volume heal $<VN> full keeps increasing the No. of entries for gluster volume heal $<vn> info healed even if healing is not done
gluster volume heal $<VN> full keeps increasing the No. of entries for gluste...
Status: CLOSED DUPLICATE of bug 863068
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: vsomyaju
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 08:12 EDT by vsomyaju
Modified: 2015-03-04 19:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 06:10:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vsomyaju 2012-10-15 08:12:25 EDT
Description of problem:

For replicate volumes, if gluster volume heal volumename full is executed and there is nothing to heal in that case gluster volume heal volumename info healed outputs the double of No. of entries healed before executing the gluster volume heal volumename full command.

Version-Release number of selected component (if applicable):


Steps to Reproduce:

1.Create replicate volume of three bricks.
2. Start the volume.
3. Create Mountpoint.
4. Kill any two bricks and from the mountpoint create some files.
5. Execute gluster volume start volumename force
6. Execute gluster volume heal volumename full
7. Execute gluster volume heal volumename info healed
8. Now again execute gluster volume heal volumename full
9. Execute gluster volume heal volumename info healed
10.Bug can be checked by executing steps 8 and 9 repeatedly and checking that Number of entries getting doubled every time.




Actual results:
1.root@c:/home/v/glustermounts# gluster volume heal volume2   info healed |grep Num
Number of entries: 21
Number of entries: 0
Number of entries: 0

[THERE IS NOTHING TO HEAL and execute gluster voluem heal vn full]
2. root@c:/home/v/glustermounts# gluster volume heal volume2 full

3, root@c:/home/v/glustermounts# gluster volume heal volume2 info healed | grep Num

Number of entries: 42
Number of entries: 0
Number of entries: 0


Expected results:
No of entries should be same every time gluster volume heal volume2 info healed is executed if no self-heal is done.

Additional info:
Comment 1 vsomyaju 2012-11-19 06:10:35 EST

*** This bug has been marked as a duplicate of bug 863068 ***

Note You need to log in before you can comment on or make changes to this bug.