Bug 866476 - Could not determine driver name for HP-Business_Inkjet_9100-Postscript.ppd and Oce-3165-Postscript.ppd
Could not determine driver name for HP-Business_Inkjet_9100-Postscript.ppd an...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic-db (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 972740 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 09:17 EDT by Tim Waugh
Modified: 2013-12-18 09:59 EST (History)
2 users (show)

See Also:
Fixed In Version: foomatic-db-4.0-41.20131218.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 09:59:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2012-10-15 09:17:03 EDT
Description of problem:
$ /usr/lib/cups/driver/foomatic list | grep 3165-
"foomatic:Oce-3165-Postscript.ppd" en "Oce" "Oce 3165 Foomatic/Postscript" "DRV:DPostscript,M0,TP;"
$ /usr/lib/cups/driver/foomatic cat foomatic:Oce-3165-Postscript.ppd
ERROR: Could not determine driver name for Oce-3165-Postscript.ppd!

Version-Release number of selected component (if applicable):
foomatic-4.0.8-13.fc18.x86_64
foomatic-db-4.0-34.20121011.fc18.noarch

How reproducible:
100%
Comment 1 Tim Waugh 2012-10-15 09:18:06 EDT
Also happens for HP Business Inkjet 9100:

$ /usr/lib/cups/driver/foomatic list | grep Inkjet_9100
"foomatic:HP-Business_Inkjet_9100-Postscript.ppd" en "HP" "HP Business Inkjet 9100 Foomatic/Postscript" "DRV:DPostscript,M0,TP;"
$ /usr/lib/cups/driver/foomatic cat foomatic:HP-Business_Inkjet_9100-Postscript.ppd
ERROR: Could not determine driver name for HP-Business_Inkjet_9100-Postscript.ppd!
Comment 2 Tim Waugh 2012-10-15 09:19:55 EDT
Found from a run of "test-cups-driver.py foomatic".  No other issues to report.
Comment 3 Jiri Popelka 2012-10-15 09:43:39 EDT
Yes, there's more of them:

for f in $(foomatic-ppdfile list | cut -f1 -d " "); do foomatic-ppdfile cat $f | grep ERROR; done
Comment 4 Tim Waugh 2012-10-15 10:10:35 EDT
I think that command might give false positives because it doesn't de-quote the driver name.

As foomatic always uses double-quotes we can do this:

for f in $(foomatic-ppdfile list | cut -f2 -d '"'); do foomatic-ppdfile cat $f | grep ERROR; done

...but I think that's the equivalent of what 'test-cups-driver.py foomatic' did.

The only other errors were 'missing executable' for some smaller drivers, which can be safely ignored.
Comment 5 Jiri Popelka 2012-10-15 12:07:39 EDT
(In reply to comment #4)
> I think that command might give false positives because it doesn't de-quote
> the driver name.

Sure, thanks.

Both of the printers seems to be needlessly on the list, I'll report it upstream.

(In reply to comment #0)
> foomatic:Oce-3165-Postscript.ppd

There's also foomatic:Oce-3165PS-Postscript.ppd and openprinting.org points to this one.

(In reply to comment #1)
> foomatic:HP-Business_Inkjet_9100-Postscript.ppd

'HP Business Inkjet 9100' looks like a nonsense, Google doesn't know anything about it.
Comment 6 Jiri Popelka 2012-10-15 13:13:02 EDT
reported upstream
https://bugs.linuxfoundation.org/show_bug.cgi?id=1078
Comment 7 Jiri Popelka 2013-12-18 09:06:03 EST
(In reply to Tim Waugh from comment #4)
> The only other errors were 'missing executable' for some smaller drivers,
> which can be safely ignored.

Listed in bug #972740, comment #0
Comment 8 Jiri Popelka 2013-12-18 09:06:35 EST
*** Bug 972740 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.