Bug 866493 - Frequent SSL renegotiations lead to poor performance
Frequent SSL renegotiations lead to poor performance
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 09:47 EDT by Thom Carlin
Modified: 2013-09-19 14:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 14:19:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 52703 None None None 2012-10-15 09:47:55 EDT
Mozilla Foundation 728715 None None None 2012-10-15 09:50:39 EDT

  None (edit)
Description Thom Carlin 2012-10-15 09:47:55 EDT
Description of problem:

In /var/log/httpd/ssl_kt_error_log, we are seeing a constant stream of:
Requesting connection re-negotiation, referer: https://fqdn/katello/sync_management/index
[info] Awaiting re-negotiation handshake, referer: https://fqdn/katello/sync_management/index
[error] Re-negotiation handshake failed: Not accepted by client!?, referer: https://fqdn/katello/sync_management/index
[info] Connection to child 5 established (server fqdn:port)
[info] Seeding PRNG with 144 bytes of entropy
[info] Initial (No.1) HTTPS request received for child 5 (server fqdn:port)
and repeats...

Version-Release number of selected component (if applicable):

CloudForms 1.1 beta

How reproducible:

Extremely frequent

Steps to Reproduce:
1. Will supply
2.
3.
  
Actual results:

Error messages above, poor performance

Expected results:

No errors, good performance

Additional info:

Believe this is related to  https://issues.apache.org/bugzilla/show_bug.cgi?id=52703 and https://bugzilla.mozilla.org/show_bug.cgi?id=728715
Comment 2 Lukas Zapletal 2013-02-12 08:16:55 EST
I have tried to disable SSLSessionCache and it did not help.

Then I tried to comment out SSLVerifyClient for /cfse location and all the errors

[error] [client 10.3x.1x.xx] Re-negotiation handshake failed

disappeared. It seems we do not need to have client certificates on this location. I need to verify this.

Also we have default log level set to info which is leaving those messages like

[Tue Feb 12 07:53:46 2013] [info] Initial (No.1) HTTPS request received for child 5 (server dell-pe1950-06.rhts.englab.brq.redhat.com:443)
[Tue Feb 12 07:53:46 2013] [info] Subsequent (No.2) HTTPS request received for child 6 (server dell-pe1950-06.rhts.englab.brq.redhat.com:443)

Setting it to default "warn" clears the log. I will prepare a patch after discussion on the list.
Comment 3 Lukas Zapletal 2013-02-12 09:50:05 EST
https://github.com/Katello/katello/pull/1562
Comment 4 Lukas Zapletal 2013-02-22 08:27:10 EST
Merged!
Comment 5 Mike McCune 2013-09-19 14:19:46 EDT
These bugs have been resolved in upstream projects for a period of months so
I'm mass-closing them as CLOSED:UPSTREAM.  If this is a mistake feel free to
re-open.

Note You need to log in before you can comment on or make changes to this bug.