This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 866525 - [abrt] ibus-1.4.99.20120914-2.fc17: switcher_run: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.99.20120914-2.fc17: switcher_run: Process /usr/libexec/ibus-u...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:103183390279cf9d8dc09986084...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 10:52 EDT by WenbinChen
Modified: 2012-10-18 06:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 21:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (2.01 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: environ (782 bytes, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: event_log (2.18 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: backtrace (21.46 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: cgroup (131 bytes, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: maps (23.37 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: dso_list (6.99 KB, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: open_fds (358 bytes, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details
File: var_log_messages (160 bytes, text/plain)
2012-10-15 10:52 EDT, WenbinChen
no flags Details

  None (edit)
Description WenbinChen 2012-10-15 10:52:05 EDT
Description of problem:
hi developer:
                     When i use firefox open a web page and that web page  play a flash with music.
Best Regards
Wenbin chen 


Version-Release number of selected component:
ibus-1.4.99.20120914-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: switcher_run
kernel:         3.6.1-1.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #5 switcher_run at switcher.c:364
: #6 panel_handle_engine_switch at panel.c:2935
: #7 __lambda26_ at panel.c:551
: #8 ___lambda26__keybinding_manager_keybinding_handler_func at panel.c:556
: #9 keybinding_manager_event_handler at keybindingmanager.c:618
: #10 _keybinding_manager_event_handler_gdk_event_func at keybindingmanager.c:154
: #11 _gdk_event_emit at gdkevents.c:69
: #17 switcher_run at switcher.c:496
: #18 panel_handle_engine_switch at panel.c:2935
: #19 __lambda26_ at panel.c:551
Comment 1 WenbinChen 2012-10-15 10:52:10 EDT
Created attachment 627495 [details]
File: core_backtrace
Comment 2 WenbinChen 2012-10-15 10:52:13 EDT
Created attachment 627496 [details]
File: environ
Comment 3 WenbinChen 2012-10-15 10:52:17 EDT
Created attachment 627497 [details]
File: event_log
Comment 4 WenbinChen 2012-10-15 10:52:24 EDT
Created attachment 627498 [details]
File: backtrace
Comment 5 WenbinChen 2012-10-15 10:52:28 EDT
Created attachment 627499 [details]
File: cgroup
Comment 6 WenbinChen 2012-10-15 10:52:31 EDT
Created attachment 627500 [details]
File: limits
Comment 7 WenbinChen 2012-10-15 10:52:39 EDT
Created attachment 627501 [details]
File: maps
Comment 8 WenbinChen 2012-10-15 10:52:43 EDT
Created attachment 627502 [details]
File: dso_list
Comment 9 WenbinChen 2012-10-15 10:52:46 EDT
Created attachment 627503 [details]
File: open_fds
Comment 10 WenbinChen 2012-10-15 10:52:49 EDT
Created attachment 627504 [details]
File: var_log_messages
Comment 11 fujiwara 2012-10-15 22:47:14 EDT
(In reply to comment #4)
> Created attachment 627498 [details]
> File: backtrace

> #0  0xb7749424 in __kernel_vsyscall ()
> No symbol table info available.
> #1  0x43e77eb4 in __GI___poll (fds=fds@entry=0xab300c78, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
>         resultvar = <optimized out>
>         oldtype = -14
>         result = <optimized out>
> #2  0x44068f5c in g_poll (fds=0xab300c78, nfds=1, timeout=-1) at gpoll.c:132
> No locals.
> #3  0x4405a3e0 in g_main_context_poll (n_fds=1, fds=0xab300c78, timeout=<optimized out>, context=0xa17a680, priority=<optimized out>) at gmain.c:3440
>         poll_func = <optimized out>
> #4  g_main_context_iterate (context=0xa17a680, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
>         max_priority = 2147483647
>         timeout = -1
>         some_ready = <optimized out>
>         nfds = 1
>         allocated_nfds = <optimized out>
>         fds = 0xab300c78
> #5  0x4405a8c3 in g_main_loop_run (loop=0xab300c68) at gmain.c:3340
>         __PRETTY_FUNCTION__ = "g_main_loop_run"
> #6  0xb7735265 in dconf_context_thread (data=0xa17a680) at dconfcontext.c:11
>         context = 0xa17a680
>         loop = <optimized out>
>         __PRETTY_FUNCTION__ = "dconf_context_thread"


I cannot reproduce your problem.
Are you still able to reproduce your problem?
Comment 12 WenbinChen 2012-10-17 08:03:58 EDT
(In reply to comment #11)
> (In reply to comment #4)
> > Created attachment 627498 [details]
> > File: backtrace
> 
> > #0  0xb7749424 in __kernel_vsyscall ()
> > No symbol table info available.
> > #1  0x43e77eb4 in __GI___poll (fds=fds@entry=0xab300c78, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
> >         resultvar = <optimized out>
> >         oldtype = -14
> >         result = <optimized out>
> > #2  0x44068f5c in g_poll (fds=0xab300c78, nfds=1, timeout=-1) at gpoll.c:132
> > No locals.
> > #3  0x4405a3e0 in g_main_context_poll (n_fds=1, fds=0xab300c78, timeout=<optimized out>, context=0xa17a680, priority=<optimized out>) at gmain.c:3440
> >         poll_func = <optimized out>
> > #4  g_main_context_iterate (context=0xa17a680, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
> >         max_priority = 2147483647
> >         timeout = -1
> >         some_ready = <optimized out>
> >         nfds = 1
> >         allocated_nfds = <optimized out>
> >         fds = 0xab300c78
> > #5  0x4405a8c3 in g_main_loop_run (loop=0xab300c68) at gmain.c:3340
> >         __PRETTY_FUNCTION__ = "g_main_loop_run"
> > #6  0xb7735265 in dconf_context_thread (data=0xa17a680) at dconfcontext.c:11
> >         context = 0xa17a680
> >         loop = <optimized out>
> >         __PRETTY_FUNCTION__ = "dconf_context_thread"
> 
> 
> I cannot reproduce your problem.
> Are you still able to reproduce your problem?

Hi fujiwara:
   After this bug open,the ibuspinyin have a update,so i can't reproduce this bug again in the same condition.So what should i do? Close this bug or continue try to reproduce this bug?

--Best Regards
--Wenbin chen
Comment 13 fujiwara 2012-10-17 21:18:29 EDT
If you see the same error, please comment here again.
Thanks for your test.
Comment 14 WenbinChen 2012-10-18 06:17:45 EDT
(In reply to comment #13)
> If you see the same error, please comment here again.
> Thanks for your test.

Ok.

Note You need to log in before you can comment on or make changes to this bug.