Bug 866530 - 'rhc setup' gets stuck in infinite loop on devenv
'rhc setup' gets stuck in infinite loop on devenv
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
: 866543 874416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 10:58 EDT by Clayton Coleman
Modified: 2015-05-14 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_BZ866530_236
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-10-15 10:58:35 EDT
1. Create a new devenv
2. Log in
3. Run 'rhc setup', input user test/test, then hit yes to upload the key:

Your public ssh key must be uploaded to the OpenShift server.  Would you like us to upload it for
you? (yes/no) yes

You can enter a name for your key, or leave it blank to use the default name. Using the same name
as an existing key will overwrite the old key.

Since you do not have any keys associated with your OpenShift account,
your new key will be uploaded as the 'default' key

<hangs infinitely with 100% CPU>

/usr/lib/ruby/gems/1.8/gems/highline-1.5.1/lib/highline.rb:735
Comment 2 Clayton Coleman 2012-10-15 11:00:46 EDT
The line came from triggering sigsegv, is @wrap_at == -1?
Comment 3 Clayton Coleman 2012-10-15 11:26:54 EDT
I tried to patch around @wrap so it wouldn't be -1, but now seeing an infinite hot loop later down.  Are we resetting $terminal or some craziness?
Comment 4 Clayton Coleman 2012-10-15 14:32:47 EDT
*** Bug 866543 has been marked as a duplicate of this bug. ***
Comment 5 Fabiano Franz 2012-10-16 23:05:10 EDT
Fixed in fork_ami_BZ866530_236.
Comment 6 joycezhang 2012-10-17 23:22:13 EDT
This bug has been verified on fork_ami_BZ866530_236. Please set the results as below when using rhc setup:


# rhc setup

Starting Interactive Setup for OpenShift's command line interface

We'll help get you setup with just a couple of questions. You can skip this in the future by
copying your config's around:

    /root/.openshift/express.conf
    /root/.ssh/

To connect to localhost enter your OpenShift login (email or Red Hat login id): test
Password: ****

Created local config file: /root/.openshift/express.conf
The express.conf file contains user configuration, and can be transferred to different computers.

Your public ssh key must be uploaded to the OpenShift server.  Would you like us to upload it for
you? (yes/no) yes

You can enter a name for your key, or leave it blank to use the default name. Using the same name
as an existing key will overwrite the old key.

Since you do not have any keys associated with your OpenShift account,
your new key will be uploaded as the 'default' key

type: ssh-rsa
content:
AAAAB3NzaC1yc2EAAAABIwAAAQEA6mTc9Oftu6XPNg78qoA745Zy46YkHj/erRTvHzlGVLqcehkuJHR6nQkJm6pCAADWHZ2IW
c2Hxo3fQ6ms0HfwaVp5avm0Z/edUD+me3SvmLlr9cReFBmwaOLxQAKQVyKXBrKbvwJ1LTYqu9fVSthodU+rnXuT102u/fB1Ma
XgdnkdDloD+q3cTG4aXzuB6WyHzRVCzHhas6B74F3VT7+ThcIyO/+27i9HfOPAT/khcEALjy1f5V5RphuxBYvC/cnxfeizbVR
P6C9gFprMkcTuQssxzfNaisM1qOx0je/InY5YYuXrgBFr1N/ZX0VQ4uytObwkkjucOAdXI/1GXh+zFQ==
fingerprint: 6e:54:fd:e1:7d:56:79:98:52:75:2d:50:02:7a:02:cc
Uploading key 'default' from /root/.ssh/id_rsa.pub
We will now check to see if you have the necessary client tools installed.

Checking for git ... found

Checking for your namespace ... not found
Your namespace is unique to your account and is the suffix of the public URLs we assign to your
applications. You may configure your namespace here or leave it blank and use 'rhc domain create'
to create a namespace later.  You will not be able to create applications without first creating
a namespace.

Please enter a namespace or leave this blank if you wish to skip this step:
test

Namespace 'test' is already in use. Please choose another.
Please enter a namespace or leave this blank if you wish to skip this step:
testa

Your domain name 'testa' has been successfully created


Checking for applications ... none found

Run 'rhc app create' to create your first application.

Below is a list of the types of application you can create: 
    * diy-0.1 - rhc app create <app name> diy-0.1
    * jbossas-7 - rhc app create <app name> jbossas-7
    * jbosseap-6.0 - rhc app create <app name> jbosseap-6.0
    * jbossews-1.0 - rhc app create <app name> jbossews-1.0
    * jenkins-1.4 - rhc app create <app name> jenkins-1.4
    * nodejs-0.6 - rhc app create <app name> nodejs-0.6
    * perl-5.10 - rhc app create <app name> perl-5.10
    * php-5.3 - rhc app create <app name> php-5.3
    * python-2.6 - rhc app create <app name> python-2.6
    * ruby-1.8 - rhc app create <app name> ruby-1.8
    * ruby-1.9 - rhc app create <app name> ruby-1.9
    * zend-5.6 - rhc app create <app name> zend-5.6

Thank you for setting up your system.  You can rerun this at any time by calling 'rhc setup'.
Comment 7 Hiro Asari 2012-11-16 14:14:52 EST
*** Bug 874416 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.