Bug 866607 - [abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:913:_getFile:NoMoreMirrorsRepoError: failure: repodata/primary.xml.gz from adobe-linux-x86_64: [Errno 256] No more mirrors to try.
[abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:913:_getFile:NoMoreMirrorsRepoErro...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:a57e92a1d9a6fa71bf4b2f78595...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 13:41 EDT by aawasthi
Modified: 2012-12-18 08:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 08:56:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.38 KB, text/plain)
2012-10-15 13:41 EDT, aawasthi
no flags Details

  None (edit)
Description aawasthi 2012-10-15 13:41:53 EDT
Version-Release number of selected component:
yum-utils-1.1.31-4.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python -tt /usr/bin/repoquery -R --resolve vlc
kernel:         3.6.1-1.fc17.x86_64

backtrace:
:yumRepo.py:913:_getFile:NoMoreMirrorsRepoError: failure: repodata/primary.xml.gz from adobe-linux-x86_64: [Errno 256] No more mirrors to try.
:
:Traceback (most recent call last):
:  File "/usr/bin/repoquery", line 1510, in <module>
:    main(sys.argv)
:  File "/usr/bin/repoquery", line 1504, in main
:    repoq.runQuery(regexs)
:  File "/usr/bin/repoquery", line 988, in runQuery
:    for p in self.doQuery(oper, prco):
:  File "/usr/bin/repoquery", line 1027, in doQuery
:    return getattr(self, "fmt_%s" % method)(*args, **kw)
:  File "/usr/bin/repoquery", line 1099, in fmt_requires
:    for pkg in self.returnByName(name):
:  File "/usr/bin/repoquery", line 839, in returnByName
:    pkgs = self.returnPkgList(patterns=[name])
:  File "/usr/bin/repoquery", line 856, in returnPkgList
:    pkgs = self.pkgSack.returnNewestByNameArch(**kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1015, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 348, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 206, in populate
:    xml = repo_get_function()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1716, in getPrimaryXML
:    return self.retrieveMD('primary')
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1639, in retrieveMD
:    return self._retrieveMD(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1698, in _retrieveMD
:    **kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 913, in _getFile
:    raise Errors.NoMoreMirrorsRepoError(errstr, errors)
:NoMoreMirrorsRepoError: failure: repodata/primary.xml.gz from adobe-linux-x86_64: [Errno 256] No more mirrors to try.
:
:Local variables in innermost frame:
:errors: None
:e: URLGrabError(256, 'No more mirrors to try.')
:start: None
:url: None
:text: 'adobe-linux-x86_64/primary'
:self: <yum.yumRepo.YumRepository object at 0x2be1f50>
:cache: True
:reget: None
:relative: 'repodata/primary.xml.gz'
:headers: ()
:checkfunc: <function checkfunc at 0x2bf28c0>
:errstr: 'failure: repodata/primary.xml.gz from adobe-linux-x86_64: [Errno 256] No more mirrors to try.'
:copy_local: 1
:kwargs: {}
:end: None
:local: '/var/tmp/yum-awasthi-rQUteu/x86_64/17/adobe-linux-x86_64/primary.xml.gz'
:size: None
Comment 1 aawasthi 2012-10-15 13:41:57 EDT
Created attachment 627573 [details]
File: core_backtrace
Comment 2 aawasthi 2012-12-18 08:56:15 EST
Worked for me later. Appears to have occurred due to Adobe repos not functioning at that time.

Note You need to log in before you can comment on or make changes to this bug.