Bug 866682 - Incorrect reports of failed login attempts
Incorrect reports of failed login attempts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 17:05 EDT by David Woodhouse
Modified: 2013-02-01 11:12 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 11:12:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2012-10-15 17:05:48 EDT
Not entirely sure if this is PAM's fault, but...

[dwmw2@shinybook ~]$ su
Password: 
Last failed login: Fri Oct 12 20:50:36 PDT 2012 from 217.108.226.49 on ssh:notty
There were 17 failed login attempts since the last successful login.
[root@shinybook dwmw2]# exit
[dwmw2@shinybook ~]$ su
Password: 
Last failed login: Fri Oct 12 20:50:36 PDT 2012 from 217.108.226.49 on ssh:notty
There were 17 failed login attempts since the last successful login.
[root@shinybook dwmw2]# 


There certainly haven't been 17 failed login attempts between my first successful login, and my second. It even admits that — the last unsuccessful attempt was 3 days ago.
Comment 1 Tomas Mraz 2012-10-15 17:40:45 EDT
su has to update the btmp file for the display to be correct.

It probably should not update it if root attempts su-ing to a regular user account though.
Comment 2 Ondrej Vasik 2012-10-16 02:46:11 EDT
Utility su is going to move to util-linux in F19 (was removed from coreutils by upstream and Karel kindly added su and runuser to their new home in util-linux).
Comment 3 Karel Zak 2012-10-16 05:30:12 EDT
(In reply to comment #1)
> su has to update the btmp file for the display to be correct.

Good point, added to upstream util-linux TODO file.
Comment 4 Karel Zak 2013-02-01 11:12:53 EST
Implemented in upstream tree, ...will be in util-linux 2.23 (f19)

Note You need to log in before you can comment on or make changes to this bug.