Bug 866697 - [abrt] evolution-3.6.1-1.fc18: camel_nntp_raw_commandv: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.6.1-1.fc18: camel_nntp_raw_commandv: Process /usr/bin/evol...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:ff4d0f77b45ddffd31f25a70a27...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 18:16 EDT by Michael Scherer
Modified: 2012-10-18 05:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 05:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (2.41 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: environ (1.53 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: backtrace (65.21 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: smolt_data (3.59 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: cgroup (127 bytes, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: maps (127.37 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: dso_list (26.61 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: build_ids (10.25 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: open_fds (3.08 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details
File: var_log_messages (1.10 KB, text/plain)
2012-10-15 18:16 EDT, Michael Scherer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 685482 None None None 2012-10-18 05:39:48 EDT

  None (edit)
Description Michael Scherer 2012-10-15 18:16:34 EDT
Description of problem:
Evolution refreshed itself, and I think this would be related to my gmane nntp account ( anonymous one ) since the backtrace speak of nntp.

Version-Release number of selected component:
evolution-3.6.1-1.fc18

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.15
backtrace_rating: 4
cmdline:        evolution
crash_function: camel_nntp_raw_commandv
kernel:         3.6.1-1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 camel_nntp_raw_commandv at /usr/lib64/evolution-data-server/camel-providers/libcamelnntp.so
: #1 camel_nntp_raw_command_auth at /usr/lib64/evolution-data-server/camel-providers/libcamelnntp.so
: #2 camel_nntp_command at /usr/lib64/evolution-data-server/camel-providers/libcamelnntp.so
: #3 nntp_folder_refresh_info_online at /usr/lib64/evolution-data-server/camel-providers/libcamelnntp.so
: #4 disco_refresh_info_sync at /lib64/libcamel-1.2.so.40
: #5 camel_folder_refresh_info_sync at /lib64/libcamel-1.2.so.40
: #6 camel_nntp_folder_new at /usr/lib64/evolution-data-server/camel-providers/libcamelnntp.so
: #7 disco_store_get_folder_sync at /lib64/libcamel-1.2.so.40
: #8 camel_store_get_folder_sync at /lib64/libcamel-1.2.so.40
: #9 e_mail_session_uri_to_folder_sync at /usr/lib64/evolution/3.6/libemail-engine.so
Comment 1 Michael Scherer 2012-10-15 18:16:36 EDT
Created attachment 627746 [details]
File: core_backtrace
Comment 2 Michael Scherer 2012-10-15 18:16:38 EDT
Created attachment 627747 [details]
File: environ
Comment 3 Michael Scherer 2012-10-15 18:16:40 EDT
Created attachment 627748 [details]
File: limits
Comment 4 Michael Scherer 2012-10-15 18:16:42 EDT
Created attachment 627749 [details]
File: backtrace
Comment 5 Michael Scherer 2012-10-15 18:16:44 EDT
Created attachment 627750 [details]
File: smolt_data
Comment 6 Michael Scherer 2012-10-15 18:16:45 EDT
Created attachment 627751 [details]
File: cgroup
Comment 7 Michael Scherer 2012-10-15 18:16:48 EDT
Created attachment 627752 [details]
File: maps
Comment 8 Michael Scherer 2012-10-15 18:16:51 EDT
Created attachment 627753 [details]
File: dso_list
Comment 9 Michael Scherer 2012-10-15 18:16:53 EDT
Created attachment 627754 [details]
File: proc_pid_status
Comment 10 Michael Scherer 2012-10-15 18:16:55 EDT
Created attachment 627755 [details]
File: build_ids
Comment 11 Michael Scherer 2012-10-15 18:16:56 EDT
Created attachment 627756 [details]
File: open_fds
Comment 12 Michael Scherer 2012-10-15 18:16:59 EDT
Created attachment 627757 [details]
File: var_log_messages
Comment 13 Milan Crha 2012-10-17 03:19:12 EDT
Thanks for a bug report. You are right with the NNTP account and refresh, that's basically what I see in the backtrace too - evolution was refreshing one of your NNTP folders, when it crashed. There are missing debuginfo packages for evolution-data-server and evolution, unfortunately, thus the backtrace is missing detailed information from the crash. Could you install debuginfo packages (of the same version as your binary packages are), please?

Was this just a one-time crash, or you got it multiple times? If the later, then it'll be nice to get the backtrace with detailed information.
Comment 14 Michael Scherer 2012-10-17 04:17:28 EDT
Nope, this occurs each time. i disabled nntp to fix for now, and i will generate a new backtrace later.
Comment 15 Milan Crha 2012-10-18 05:39:48 EDT
Thanks for the update. I'm trying to reproduce this, while I found other issues with NNTP. I'm testing further, but meanwhile, I found upstream bug [1] about the same, thus I'm moving this there. Feel free to CC there yourself, as any further updates will be done there.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=685482

Note You need to log in before you can comment on or make changes to this bug.