Bug 866740 - Unable to build when using CSP 0.27.4
Unable to build when using CSP 0.27.4
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 22:58 EDT by Lee Newson
Modified: 2013-06-06 21:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.27.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:29:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2012-10-15 22:58:15 EDT
I'd upgraded to day to 0.27.4, and when I ran the assemble, I got

Beginning work on en-US
topics/Assigning_an_Administrator_or_User_Role_to_a_Resource1.xml:6: validity error : ID Assigning_an_Administrator_or_User_Role_to_a_Resource1 already defined
topics/SPICE1.xml:6: validity error : ID SPICE1 already defined
topics/Assigning_an_Administrator_or_User_Role_to_a_Resource1-1.xml:6: validity error : ID Assigning_an_Administrator_or_User_Role_to_a_Resource1-1 already defined
topics/Assigning_an_Administrator_or_User_Role_to_a_Resource1-2.xml:6: validity error : ID Assigning_an_Administrator_or_User_Role_to_a_Resource1-2 already defined
DTD Validation failed: 
ERROR: Unable to assemble the Content Specification because an error occured while running Publican. (exit code: 2)

I looked at the topics, which don't contain any IDs, so I'm thinking... maybe regression? 

Note from Lee:

The book this was tried on was the RHEV Administration Guide (8844), revision 310147
Comment 1 Lee Newson 2012-10-15 23:10:10 EDT
Fixed in 0.27.5.

Cause:

The cause comes from using topics with different revisions. The reason this worked in 0.27.2 was that although a revision was specified it would only use one revision or the other to actually generate the content. This in-turn meant that all topics were based off two different Properties, however they had the same Fixed URL. When the issue was fixed regarding the revision Fixed URLs it exposed this bug, as now the Spec Topic titles were based off two different properties with different Fixed URLs. This in-turn broke the unique ID processing as it assumes two topics with the same ID don't exist with the same FixedURL.

Consequence:

You were unable to build books with topics that had different revisions.

Fix:

Ensure that the correct Topic is applied to the correct SpecTopic when processing topics. Also update the Unique ID processing to take revision in to account.
Comment 2 Lee Newson 2013-06-06 21:29:53 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.