Bug 866755 - Incorrect directory paths in Win chapter
Incorrect directory paths in Win chapter
Status: CLOSED NOTABUG
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 00:21 EDT by Misha H. Ali
Modified: 2012-10-23 21:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 21:10:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-10-16 00:21:58 EDT
For Chapter 3. Installing Enterprise Web Server on Windows:

* Procedure 3.3. Extracting the ZIP File

"Files are extracted in C:\Program Files\jboss-ews-2.0. If you wish to change the httpd configuration (for example, add mod_cluster), edit the httpd.conf file in the C:\Program Files\jboss-ews-2.0\etc\httpd\conf folder."

There is no conf folder in \etc\httpd, so need to confirm where the httpd.conf file lives now.

------

* Procedure 3.4. Setting Environment Variables

"You will also need to add C:\Program Files\jboss-ews-2.0\bin to the PATH environment variable of the user the service runs under. This is SYSTEM by default. Without this, the SSL Connector will fail to work."

\bin does not exist, what link do we now need to add to the PATH environment variable for the SSL connector to work?

-----

* Procedure 3.6. Installing Tomcat

"For Tomcat 6, the command is:
 C:\> cd /D "C:\Program Files\jboss-ews-2.0\share\tomcat6\bin""

there is no bin folder in tomcat6 or tomcat7. What is the new folder to use?

------

* Procedure 3.7. Installing HTTP

"Change to the bin folder of your new installation:
C:\> cd /D "C:\Program Files\jboss-ews-2.0\bin""

No bin folder exists at that location. Where to change into to run the httpd -k install command?

-----

* Procedure 3.9. Removing SSL

"Go to C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d"

conf.d does not exist there. Where is the ssl.conf file now?

-----

* Procedure 3.10. Configuring mod_jk

"In C:\Program Files\jboss-ews-2.0\etc\httpd\conf\ create workers.properties "

No conf directory in that location. Where to create this file now?

------

* Procedure 3.10. Configuring mod_jk

"In C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\ create mod_jk.conf"

No conf.d folder here either, where to create mod_jk.conf now?

-------

* Procedure 3.10. Configuring mod_jk

"You can also use the sample files mod_jk.conf.sample and workers.properties.sample available in C:\Program Files\jboss-ews-2.0\etc\httpd\conf: modify their content as needed and rename them to mod_jk.conf and workers.properties."

Same as the two above, where are these sample files located now?

--------

* Procedure 3.11. Configuring mod_cluster

"In the C:\Program Files\jboss-ews-2.0\etc\httpd\conf\httpd.conf file, add the hash (#) sign at the beginning of the following line to disable mod_proxy_balancer.so:"

Where is the httpd.conf file?

--------

* Procedure 3.11. Configuring mod_cluster

"Create the file C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf."

Where to create this now?

---------

===========
Chapter 6. Monitoring Enterprise Web Server with JBoss Operations Network
============

* Procedure 6.2. Configuring Monitoring

"on Windows open C:\Program Files\jboss-ews-2.0\sbin\tomcat<VERSION>.sh"

Where is this script located?

----------

Libor, since your team has a windows environment and would know the correct paths from testing, can you fill in the blanks here? Also adding a need info for Mladen for the same reason.
Comment 1 Mladen Turk 2012-10-16 01:11:24 EDT
I'm really not sure at what you are looking at.
Seems you don't have any folder required. Are you using a correct archive(s) ?

For windows we have three archives
jboss-ews-httpd-2.0
jboss-ews-application-servers-2.0
jboss-ews-webserver-connectors-2.0

Then we have jboss-ews-2.0
but this is archive containing only sources.
Comment 2 Misha H. Ali 2012-10-16 01:15:57 EDT
Sorry Mladen, we have some doc stage fail, I expected to be able to point to the following on the stage. Pasting it instead:

Added note about this being the symbolic structure after postinstall.bat runs and amended to the following:

jboss-ews-2.0
    |
    |-- etc
         |-- httpd
               |-- logs
               |-- modules
               '-- run
    |-- share
         |-- tomcat6
         |-- tomcat7
         |-- apache-tomcat-6.0.35
                |-- logs
                |-- temp
                '-- work
         |-- apache-tomcat-7.0.30
                |-- logs
                |-- temp
                '-- work

I'm looking at the above and then at the other links in the chapter. Would they still be applicable or do they need to be changed to conform to the dir structure above?
Comment 3 Mladen Turk 2012-10-17 00:28:55 EDT
First there is no more postinstall.bat
We have now two postinstall scripts
1. postinstall.httpd.bat
2. postinstall.tomcat.bat

The reason why we need two is to be able to have either httpd or application-servers packages installed (or both)

The same is for Solaris where we have .postinstall.httpd and .postinstall.tomcat

So after running postinstall.httpd(.bat) the structure is
jboss-ews-2.0
    |
    |-- etc
         |-- httpd
               |-- logs
               |-- modules
               '-- run

... and after running postinstall.tomcat(.bat)
jboss-ews-2.0
    |
    |-- share
         |-- tomcat6
         |-- tomcat7
         |-- apache-tomcat-6.0.35
                |-- logs
                |-- temp
                '-- work
         |-- apache-tomcat-7.0.30
                |-- logs
                |-- temp
                '-- work


As you can see nothing changed, except that it's now split into two files each being in corresponding archive file.
Comment 4 Misha H. Ali 2012-10-23 21:10:31 EDT
Thanks for the clarification, Mladen. So I will assume that the paths listed in comment#0 are still OK. Setting this to closed NOTABUG unless someone thinks there is a reason to reopen it.

Note You need to log in before you can comment on or make changes to this bug.