Bug 866769 - Saving indicator on translation textarea is shown forever when a user saves without making any modifications
Saving indicator on translation textarea is shown forever when a user saves w...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
high Severity medium
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 01:46 EDT by David Mason
Modified: 2012-11-07 01:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20121019-0031).
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:18:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-10-16 01:46:22 EDT
Description of problem:
In translation editor, if a user uses Ctrl+Enter or clicks button to save as approved on, but the text flow is already approved and there have not been any changes since the last save, an indicator showing "saving" is shown on the text area. The indicator remains until content is changed.
The same occurs when saving as fuzzy for a textflow that has not been changed and is already marked as fuzzy.

Version-Release number of selected component (if applicable):
1.8-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1.Open editor in any project with edit permission
2.Focus cursor in an approved translation that has some text
3.Press Ctrl+Enter
  
Actual results:
 - "Saving" is shown in the text area and does not go away.

Expected results:
 - "Saving" is not shown when there are no changes to save

Additional info:
May want to show "No changes to save" in the cell for a short time so users can tell that their command to save worked, but was a no-op.
Comment 1 Patrick Huang 2012-10-16 01:49:45 EDT
committed in master:
https://github.com/zanata/zanata/commit/c1c50fb96b4fb7084768ae6df6050515f1da8c38
Comment 2 Ding-Yi Chen 2012-10-18 23:11:37 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20121019-0031)
Comment 3 Sean Flanigan 2012-11-07 01:18:39 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.