Bug 866788 - GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat
GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng (Show other bugs)
2.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 02:59 EDT by Prasanth
Modified: 2014-07-11 02:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-25 22:36:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2012-10-16 02:59:10 EDT
Description of problem: yum update fails on RHS 2.0 server while trying to retrieve GPG keys

Version-Release number of selected component (if applicable):

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.2 (Santiago)

# uname -r
2.6.32-220.23.1.el6.x86_64

# rhn-channel -l
rhel-x86_64-server-6-rhs-2.0
rhel-x86_64-server-6.2.z

How reproducible: Running yum update command 


Actual results:

----------
Install       2 Package(s)
Upgrade      20 Package(s)

Total size: 44 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat


GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat
----------

Additional info: 

# ls -al /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat
ls: cannot access /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat: No such file or directory

a.) Even doing 'yum update -y' a second time or multiple times doesn't solve this.

b.) Disabling gpgcheck in /etc/yum.conf also doesn't work. However, "yum update -y --nogpgcheck" works fine. Please find below:

-----------------------------------
# less /etc/yum.conf |grep gpg
gpgcheck=0

# yum update
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id,
              : protectbase, rhnplugin, security, subscription-manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
Updating certificate-based repositories.
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
.....
.......

Install       2 Package(s)
Upgrade      20 Package(s)

Total size: 44 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat


GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat


# yum update --nogpgcheck
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id,
              : protectbase, rhnplugin, security, subscription-manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
Updating certificate-based repositories.
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package device-mapper-multipath.x86_64 0:0.4.9-56.el6 will be updated
....
......
Install       2 Package(s)
Upgrade      20 Package(s)


Installed:
  kernel.x86_64 0:2.6.32-220.26.1.el6                            kernel-devel.x86_64 0:2.6.32-220.26.1.el6                           

Updated:
  device-mapper-multipath.x86_64 0:0.4.9-56.el6_3.1              device-mapper-multipath-libs.x86_64 0:0.4.9-56.el6_3.1              
  dmidecode.x86_64 1:2.11-2.el6_1                                dracut.noarch 0:004-256.el6_2.2                                     
  dracut-kernel.noarch 0:004-256.el6_2.2                         glusterfs.x86_64 0:3.3.0.2rhs-30.el6rhs                             
  glusterfs-fuse.x86_64 0:3.3.0.2rhs-30.el6rhs                   glusterfs-geo-replication.x86_64 0:3.3.0.2rhs-30.el6rhs             
  glusterfs-rdma.x86_64 0:3.3.0.2rhs-30.el6rhs                   glusterfs-server.x86_64 0:3.3.0.2rhs-30.el6rhs                      
  kernel-firmware.noarch 0:2.6.32-220.26.1.el6                   kernel-headers.x86_64 0:2.6.32-220.26.1.el6                         
  kpartx.x86_64 0:0.4.9-56.el6_3.1                               pulseaudio-libs.x86_64 0:0.9.21-14.el6_2                            
  tzdata.noarch 0:2012f-1.el6                                    vdsm.x86_64 0:4.9.6-16.el6rhs                                       
  vdsm-cli.noarch 0:4.9.6-16.el6rhs                              vdsm-gluster.noarch 0:4.9.6-16.el6rhs                               
  vdsm-python.noarch 0:4.9.6-16.el6rhs                           vdsm-reg.noarch 0:4.9.6-16.el6rhs                                   

Complete!
-------------------------------
Comment 2 Anthony Towns 2012-11-02 00:14:16 EDT
This was a channel misconfiguration. It should be fixed now.
Comment 3 Prasanth 2012-11-15 04:48:20 EST
Confirmed that this reported issue is not seen anymore. Marking it as Verified.

Note You need to log in before you can comment on or make changes to this bug.