Bug 866863 - [whql][netkvm]NDISTest6.5[2 machine] - Packet Filters failed on windows 2k8
[whql][netkvm]NDISTest6.5[2 machine] - Packet Filters failed on windows 2k8
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Cao
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 04:09 EDT by dengmin
Modified: 2014-07-11 02:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 06:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dengmin 2012-10-16 04:09:39 EDT
Description of problem:
The job named Packet Filters failed on windows 2008 32bits OS

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-39

How reproducible:
4 times - 4 Failed

Steps to Reproduce:
1.Boot up two guests 
  /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-32-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:11:15:36:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:11:17:26:39:12,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:11:13:26:49:13,bus=pci.0,addr=0x6 -uuid 6937373b-492e-4eef-bedd-f2097e6b0fda -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-32-nic1,server,nowait -mon chardev=111a,mode=readline  -spice port=5931,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio
 
 /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-32-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:24:05:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:10:22:15:39:02,bus=pci.0,addr=0x5 -uuid f9c00fe7-2466-4789-b391-8b56965d5081 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111b,path=/tmp/monitor-win2k8-32-nic2,server,nowait -mon chardev=111b,mode=readline -spice port=5932,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio
2.Submit job named NDISTest6.5[2 machine] - Packet Filters  on HCK
  
Actual results:
The job failed due to the following reason -
-------------------------------------------------------------------------------
Title Result 
  Failed 
 Start Test 10/8/2012 8:00:38.129 PM Checking for discrepancies between advertised and probed packet filters. 
Message 10/8/2012 8:00:39.129 PM NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed: Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while retrieving bind parameters for Red Hat VirtIO Ethernet Adapter 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x88888 
Error Text:   Error 0x00088888 
End Test 10/8/2012 8:00:39.129 PM Checking for discrepancies between advertised and probed packet filters. 
Result:   Fail 
Repro:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRun64105C4A-5EA5-43D3-A01F-7F6AB21CFD6D\ndistest.net\ndistest.exe /logo /auto /client /target:Miniport /tc:PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&2&20 /support:{A5E2B462-459A-4E76-8548-3300E9B78BEB} /msg:{55DA13D1-9F4B-4CC7-8AE1-E6F3EA7BA9ED} /jobs:lan\PacketFilters.cpp 
-------------------------------------------------------------------------------

Expected results:
The job passed smoothly.

Additional info:
Comment 2 Yan Vugenfirer 2012-10-16 05:13:27 EDT
Hi,

1. Please attack fu log (cpk).

2. Is this HCT or WLK?

3. Please check the VM: "NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed: Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while retrieving bind parameters for Red Hat VirtIO Ethernet Adapter"

Could it be that adapter is disabled after previous test?


Thanks,
Yan.
Comment 3 Yan Vugenfirer 2012-10-16 05:13:41 EDT
Hi,

1. Please attack full log (cpk).

2. Is this HCT or WLK?

3. Please check the VM: "NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed: Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while retrieving bind parameters for Red Hat VirtIO Ethernet Adapter"

Could it be that adapter is disabled after previous test?


Thanks,
Yan.
Comment 4 Mike Cao 2012-10-16 05:58:51 EDT
(In reply to comment #3)
> Hi,
> 
> 1. Please attack full log (cpk).
> 
> 2. Is this HCT or WLK?

All jobs now reported is using HCK

Mike
> 
> 3. Please check the VM:
> "NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed:
> Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
> Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while
> retrieving bind parameters for Red Hat VirtIO Ethernet Adapter"
> 
> Could it be that adapter is disabled after previous test?
> 
> 
> Thanks,
> Yan.
Comment 5 dengmin 2012-10-16 06:13:12 EDT
(In reply to comment #3)
> Hi,
> 
> 1. Please attack full log (cpk).
> 
> 2. Is this HCT or WLK?
> 
> 3. Please check the VM:
> "NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed:
> Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
> Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while
> retrieving bind parameters for Red Hat VirtIO Ethernet Adapter"
> 
> Could it be that adapter is disabled after previous test?
> 
> 
> Thanks,
> Yan.

 Hi Yan,
    Will double check the adapter's status.
 Thanks 
 Min
Comment 7 dengmin 2012-10-17 06:10:20 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > Hi,
> > 
> > 1. Please attack full log (cpk).
> > 
> > 2. Is this HCT or WLK?
> > 
> > 3. Please check the VM:
> > "NDISTest::NDISTestCore::TestServices::Open::GetNdisBindParameters failed:
> > Messenger::SendCommand() failed. Status 0x32 - NDIS_STATUS (0x00000032) 
> > Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while
> > retrieving bind parameters for Red Hat VirtIO Ethernet Adapter"
> > 
> > Could it be that adapter is disabled after previous test?
> > 
> > 
> > Thanks,
> > Yan.
> 
>  Hi Yan,
>     Will double check the adapter's status.
>  Thanks 
>  Min

   Double check the netkvm status and make sure it is available before running the job but it still can be reproduced.
   Upload the related HCK files to the bug.
Comment 8 dengmin 2012-10-17 06:25:36 EDT
Created attachment 628655 [details]
hck
Comment 9 dengmin 2012-10-17 23:04:16 EDT
  The similar issue can be found on windows 2008 64 guest.
Comment 10 Mike Cao 2012-10-19 03:26:55 EDT
Since We did not hit this issue on virtio-win-prewhql-35 ,
So it is a Regression bug .
Comment 11 Ronen Hod 2012-10-28 10:27:08 EDT
Since it is a HCK issue deferring to RHEL6.5
Comment 12 Dmitry Fleytman 2012-10-30 12:55:21 EDT
The error message is:
Error 10/8/2012 8:00:39.129 PM Failed with exception code 50 while retrieving bind parameters for Red Hat VirtIO Ethernet Adapter.

This means that there is a problem with client nodes configuration and not in real test scenario.

Please try following sequence to fix the issue:
    1. Close all ndis-test related applications running on HCK clients
    2. Uninstall NetKVM driver for all RedHat adapters on all clients(Device Manager --> Rings Click --> Uninstall --> Delete driver software)
    3. Reboot all clients
    4. Install drivers again for all Redhat adapters on all clients
    5. Reboot all clients
    6. Try to repeat this test

We saw a few similar problems, this sequence usually helps.
Comment 13 dengmin 2012-11-27 01:45:52 EST
(In reply to comment #12)
> The error message is:
Error 10/8/2012 8:00:39.129 PM Failed with exception
> code 50 while retrieving bind parameters for Red Hat VirtIO Ethernet
> Adapter.

This means that there is a problem with client nodes configuration
> and not in real test scenario.

Please try following sequence to fix the
> issue:
    1. Close all ndis-test related applications running on HCK
> clients
    2. Uninstall NetKVM driver for all RedHat adapters on all
> clients(Device Manager --> Rings Click --> Uninstall --> Delete driver
> software)
    3. Reboot all clients
    4. Install drivers again for all
> Redhat adapters on all clients
    5. Reboot all clients
    6. Try to
> repeat this test

We saw a few similar problems, this sequence usually helps.

Ongoing,I will update the results as soon as I get the results.
Comment 14 dengmin 2012-11-27 04:51:29 EST
Hi,
  I setup clean guests with build 46 installed and submit the job to HCK,the job failed too, and I refer to your suggestions - comments13,the job still failed.
Thanks
Min.
Comment 15 Dmitry Fleytman 2012-12-18 09:09:04 EST
Hi,

What do you see in the logs on new setup. Are they different. Could you attach the new logs as well?

Thanks,
Dmitry

(In reply to comment #14)
> Hi,
>   I setup clean guests with build 46 installed and submit the job to HCK,the
> job failed too, and I refer to your suggestions - comments13,the job still
> failed.
> Thanks
> Min.
Comment 16 Mike Cao 2012-12-18 09:37:19 EST
(In reply to comment #15)
> Hi,
> 
> What do you see in the logs on new setup. Are they different. Could you
> attach the new logs as well?
> 
> Thanks,
> Dmitry
> 
Hi, Dmitry

The job failed on WLK1.6 too ,We use MSFT Filter to pass it ,referring to https://sysdev.microsoft.com/en-US/Hardware/EC/ECDetails.aspx?id=2966  .

Since This issue failed on HCK as well ,Does it mean we need to request a similar filter on HCK as the above one ?

Thanks,
Mike
Comment 17 Dmitry Fleytman 2012-12-20 07:10:08 EST
According to our investigation this is a bug in HCK suite and there is an errata that covers the issue: https://sysdev.microsoft.com/en-US/Hardware/EC/FilterDetail.aspx?id=374

Please, verify it.
Comment 18 Dmitry Fleytman 2012-12-20 07:12:21 EST
Hi Mike

The link you posted is not for this test, it's for InvalidPackets, but we've found another errata that should cover this one. Please see my previous comment.

Dmitry

(In reply to comment #16)
> (In reply to comment #15)
> > Hi,
> > 
> > What do you see in the logs on new setup. Are they different. Could you
> > attach the new logs as well?
> > 
> > Thanks,
> > Dmitry
> > 
> Hi, Dmitry
> 
> The job failed on WLK1.6 too ,We use MSFT Filter to pass it ,referring to
> https://sysdev.microsoft.com/en-US/Hardware/EC/ECDetails.aspx?id=2966  .
> 
> Since This issue failed on HCK as well ,Does it mean we need to request a
> similar filter on HCK as the above one ?
> 
> Thanks,
> Mike
Comment 19 Mike Cao 2013-01-06 00:49:35 EST
(In reply to comment #17)
> According to our investigation this is a bug in HCK suite and there is an
> errata that covers the issue:
> https://sysdev.microsoft.com/en-US/Hardware/EC/FilterDetail.aspx?id=374
> 
> Please, verify it.

You are right ,Filter 645 can make this job pass ,We should update filter database more frequently.

Mike
Comment 20 Mike Cao 2013-01-06 00:57:29 EST
Since MSFT Filter Can make the job pass ,and this is not a blocker anymore unless the filter expired.
Remove Blocker flag
Comment 24 Dmitry Fleytman 2013-04-04 04:22:43 EDT
(In reply to comment #19)
> (In reply to comment #17)
> > According to our investigation this is a bug in HCK suite and there is an
> > errata that covers the issue:
> > https://sysdev.microsoft.com/en-US/Hardware/EC/FilterDetail.aspx?id=374
> > 
> > Please, verify it.
> 
> You are right ,Filter 645 can make this job pass ,We should update filter
> database more frequently.
> 
> Mike

Mike,

I'm assigning this issue back to you, in case HCK filter helps indeed, please close it.

Dmitry

Note You need to log in before you can comment on or make changes to this bug.