Bug 866916 - volume info displays information about a brick that has already been removed
volume info displays information about a brick that has already been removed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks: 867379
  Show dependency treegraph
 
Reported: 2012-10-16 06:07 EDT by Krutika Dhananjay
Modified: 2015-11-03 18:04 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 867379 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:42:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2012-10-16 06:07:31 EDT
Description of problem:
Volume info command continues to display information about a brick even after its removal.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.In a two-machine cluster, create a volume with two bricks, one on each machine (say B1 on M1 and B2 on M2).
2.Execute remove-brick on M1 to remove the brick on M2 (i.e., B2).
3.Do volume info on M1.
  
Actual results:

Volume info displays information about B2, even after its removal.

Expected results:

Volume info should only display information about B1.

Additional info:

[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
----------------------------------------------------------
[root@kd glusterfs]# gluster volume remove-brick xyz 192.168.122.250:/home/xyzab start
volume remove-brick: success
---------------------------------------------------------
[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
----------------------------------------------------------
[root@kd glusterfs]# gluster volume remove-brick xyz 192.168.122.250:/home/xyzab commit
volume remove-brick: success
---------------------------------------------------------
[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
Comment 1 Amar Tumballi 2012-10-23 14:25:57 EDT
can you check if its happening upstream? (also try with patch http://review.gluster.org/4127)
Comment 2 krishnan parthasarathi 2012-10-23 23:09:43 EDT
We 'execute' glusterd_brick_stop only if glusterd has bricks local to it that need to be removed. Since in remove-brick we have made stopping and deleting of bricks 'atomic', the 'delete' (from bricks list) is lost along with glusterd_brick_stop in that peer(s).
Comment 3 krishnan parthasarathi 2012-10-24 03:50:14 EDT
http://review.gluster.com/4128 (upstream master)
Comment 4 Vijay Bellur 2012-10-25 02:33:50 EDT
CHANGE: http://review.gluster.org/4128 (glusterd: Remove brick from brick list on all nodes.) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.