Bug 866924 - demo/jboss-seam-2.3.0.Final-redhat-1/examples/readme.txt need to be updated; refers to community AS7 and Seam
demo/jboss-seam-2.3.0.Final-redhat-1/examples/readme.txt need to be updated; ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR2
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3 seam-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 06:33 EDT by Marek Schmidt
Modified: 2012-11-30 10:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-10-16 06:33:25 EDT
Description of problem:

The readme file
demo/jboss-seam-2.3.0.Final-redhat-1/examples/readme.txt

has multiple issues:

1. "Below is a list of examples with a brief description." lists only a single example.

2. It mentions "JBoss AS 7.1.1" and "JBoss AS 7", instead of EAP6

3. The "How to Build and Deploy an Example on JBoss AS" sections 1 and 2 are not applicable to EAP6 / WFK2.1 and should be removed

4. The sections "Running integration test(s) in Eclipse" and "Debugging of integration test(s) in Eclipse" link to an outdated/incomplete documentation and should be removed.


Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1
Comment 2 Tomas Remes 2012-11-08 04:03:23 EST
This is still not correct - especially point number 4 in Marek's comment above. 

At first there is no jbossas-remote-7 profile in the examples. Profile's name is arq-jbossas-7-remote. 

For second these steps don't work because of missing some build step, which would create test deployment. It is needed to call "mvn clean package", which can be done in Eclipse via Maven build configuration.
Comment 3 Marek Novotny 2012-11-10 07:59:14 EST
(In reply to comment #2)
> This is still not correct - especially point number 4 in Marek's comment
> above. 
REMOVED from examples/readme.txt

> 
> At first there is no jbossas-remote-7 profile in the examples. Profile's
> name is arq-jbossas-7-remote. 
What are you referring here?  There is property jbossas-remote-7 which activates the profile, readme.txt doesn't specify profile, but only activation of the profile, that is different case.

mvn clean install -Darquillian=jbossas-remote-7

that is correct ^^^ and only one reference to integration testing launcher

> 
> For second these steps don't work because of missing some build step, which
> would create test deployment. It is needed to call "mvn clean package",
> which can be done in Eclipse via Maven build configuration.

that ^^ is now outdated as point 4 were removed ^^^
Comment 4 Tomas Remes 2012-11-12 04:15:41 EST
The comment about profile's name was intended from Eclipse point of view. So It can be considered as resolved by removing the specified section.
Comment 6 Marek Schmidt 2012-11-16 09:56:32 EST
Verified on WFK 2.1.0.CR2
Comment 7 Karel Piwko 2012-11-30 10:34:06 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.