Bug 866936 - [RFE] [build] Reorganize the drivers tree to match the final RPM tree structure
[RFE] [build] Reorganize the drivers tree to match the final RPM tree structure
Status: CLOSED DUPLICATE of bug 841162
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 07:10 EDT by Xiaoqing Wei
Modified: 2013-07-01 00:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-05 01:19:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2012-10-16 07:10:25 EDT
Description of problem:

win8 cant install virtio-net-pci driver due to netkvm.sys missing in virtio-win

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-41

How reproducible:
100%

Steps to Reproduce:
1. boot a Win8 vm w/ virtio-net-pci.
2. install netkvm driver(the Win8 one).
3.
  
Actual results:
Cant install

Expected results:
install success

Additional info:

1) Win8 guest can install the Win7 driver and work well.
2) copy the netkvm.sys from the Win7 folder to Win8 folder, then try install, can success.
Comment 2 Vadim Rozenfeld 2012-10-16 07:38:35 EDT
Did you fail to install or is it missing?

I believe the first one, because it is definitely included into
virtio-win zip:

├── Win8
│   ├── amd64
│   │   ├── balloon.cat
│   │   ├── balloon.inf
│   │   ├── balloon.pdb
│   │   ├── balloon.sys
│   │   ├── blnsvr.exe
│   │   ├── blnsvr.pdb
│   │   ├── netkvm.cat
│   │   ├── netkvmco.dll
│   │   ├── netkvm.inf
│   │   ├── NetKVM.pdb
│   │   ├── NetKVM.sys
│   │   ├── readme.doc
│   │   ├── vioscsi.cat
│   │   ├── vioscsi.inf
│   │   ├── vioscsi.pdb
│   │   ├── vioscsi.sys
│   │   ├── vioser.cat
│   │   ├── vioser.inf
│   │   ├── vioser.pdb
│   │   ├── vioser.sys
│   │   ├── viostor.cat
│   │   ├── viostor.inf
│   │   ├── viostor.pdb
│   │   ├── viostor.sys
│   │   └── WdfCoInstaller01011.dll
│   └── x86
│       ├── balloon.cat
│       ├── balloon.inf
│       ├── balloon.pdb
│       ├── balloon.sys
│       ├── blnsvr.exe
│       ├── blnsvr.pdb
│       ├── netkvm.cat
│       ├── netkvmco.dll
│       ├── netkvm.inf
│       ├── NetKVM.pdb
│       ├── NetKVM.sys
│       ├── readme.doc
│       ├── vioscsi.cat
│       ├── vioscsi.inf
│       ├── vioscsi.pdb
│       ├── vioscsi.sys
│       ├── vioser.cat
│       ├── vioser.inf
│       ├── vioser.pdb
│       ├── vioser.sys
│       ├── viostor.cat
│       ├── viostor.inf
│       ├── viostor.pdb
│       ├── viostor.sys
│       └── WdfCoInstaller01011.dll

Best regards,
Vadim.
Comment 3 Xiaoqing Wei 2012-10-17 02:12:35 EDT
(In reply to comment #2)
> Did you fail to install or is it missing?
> 
> I believe the first one, because it is definitely included into
> virtio-win zip:
> 
> ├── Win8
> │   ├── amd64
...
> │   │   ├── NetKVM.pdb
> │   │   ├── NetKVM.sys

Oops, my bad, these files are upper case, while the other guests using lowwer case.

qe have a script that covert such virtio-win-prewhql.zip  into virtio-win.iso/vfd, and make the dir path same as virtio-win.iso(from virtio-win.rpm), the script expects Win8 driver file in lowwer case too...

I was trying install w/ the re-pack -41 driver, so the upper case files are missing. :(
need to update that script(and w/ the NETKVM.sys NETKVM.pdb, install success, just w/ a warning).

but BTW, Vadim:
why dont make the virtio-win-prewhql's dir structure as same as the whqled one ?
our autotest expects the driver dir is same as whqled one, so we have to re-pack virtio-win-prewhql driver every build.

Thanks,
Xiaoqing.
Comment 4 Vadim Rozenfeld 2012-10-17 05:40:45 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Did you fail to install or is it missing?
> > 
> > I believe the first one, because it is definitely included into
> > virtio-win zip:
> > 
> > ├── Win8
> > │   ├── amd64
> ...
> > │   │   ├── NetKVM.pdb
> > │   │   ├── NetKVM.sys
> 
> Oops, my bad, these files are upper case, while the other guests using
> lowwer case.
> 
> qe have a script that covert such virtio-win-prewhql.zip  into
> virtio-win.iso/vfd, and make the dir path same as virtio-win.iso(from
> virtio-win.rpm), the script expects Win8 driver file in lowwer case too...
> 
> I was trying install w/ the re-pack -41 driver, so the upper case files are
> missing. :(
> need to update that script(and w/ the NETKVM.sys NETKVM.pdb, install
> success, just w/ a warning).
> 
> but BTW, Vadim:
> why dont make the virtio-win-prewhql's dir structure as same as the whqled
> one ?
> our autotest expects the driver dir is same as whqled one, so we have to
Hi Xiaoqing,
do you mean out installation CD image layout?
The problem here is tat our build works on per-driver, not per-OS base.
So it means that, for example, we build NetKvm drivers for all supported OSes,
then go to balloon and repeat the same loop, etc.
 
> re-pack virtio-win-prewhql driver every build.
> 
Technically, we can re-pack the drivers at the last stage of our build procedure. I see no problem here.

Best regards,
Vadim.
> Thanks,
> Xiaoqing.
Comment 5 Xiaoqing Wei 2012-10-17 05:49:31 EDT
(In reply to comment #4)

Hi Vadim,
> do you mean out installation CD image layout?

Yes, I mean the cdrom/floppy from the installation of virtio-win.rpm

> Technically, we can re-pack the drivers at the last stage of our build
> procedure. I see no problem here.

That will be very Cool !!!


Thanks,
Xiaoqing.
Comment 6 Vadim Rozenfeld 2012-10-17 06:04:25 EDT
(In reply to comment #5)
> (In reply to comment #4)
> 
> Hi Vadim,
> > do you mean out installation CD image layout?
> 
> Yes, I mean the cdrom/floppy from the installation of virtio-win.rpm
> 
> > Technically, we can re-pack the drivers at the last stage of our build
> > procedure. I see no problem here.
> 
> That will be very Cool !!!
> 
Please open a new bug targeted to rhel6.5
Cheers,
Vadim.
> 
> Thanks,
> Xiaoqing.
Comment 7 Ronen Hod 2012-10-24 02:48:39 EDT
Looks like we are OK for 6.4. So moving to 6.5 as an RFE (comment 5 , 4, 3)
Comment 8 Mike Cao 2013-01-05 01:19:42 EST

*** This bug has been marked as a duplicate of bug 841162 ***

Note You need to log in before you can comment on or make changes to this bug.