Bug 866946 - LVM triggers WARNING: at fs/buffer.c:1164 mark_buffer_dirty
LVM triggers WARNING: at fs/buffer.c:1164 mark_buffer_dirty
Status: CLOSED DUPLICATE of bug 679930
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 07:28 EDT by Zdenek Kabelac
Modified: 2012-11-09 11:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-09 11:32:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2012-10-16 07:28:01 EDT
Description of problem:

Execution of lvm2 test suite  (shell/snapshot-autoumount-dmeventd.sh)
triggers this kernel Warning message:

evice-mapper: snapshots: Invalidating snapshot: Unable to allocate exception.
Buffer I/O error on device dm-5, logical block 1
type=1400 audit(1350380792.802:18782): avc:  denied  { read } for  pid=2544 comm="umount" path="/proc/2412/mounts" dev=proc ino=362676 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=file
lost page write due to I/O error on dm-5
Buffer I/O error on device dm-5, logical block 132
lost page write due to I/O error on dm-5
Buffer I/O error on device dm-5, logical block 133
lost page write due to I/O error on dm-5
------------[ cut here ]------------
WARNING: at fs/buffer.c:1164 mark_buffer_dirty+0x82/0xa0() (Tainted: G           ---------------  T)
Hardware name: KVM
Modules linked in: raid0 ext2 dm_zero ext3 jbd dm_log_userspace dm_snapshot dm_thin_pool(T) dm_persistent_data dm_bufio libcrc32c dm_raid raid10 raid1 raid456 async_raid6_recov async_pq raid6_pq async_xor xor async_memcpy async_tx sunrpc ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter ip_tables ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables ipv6 microcode virtio_balloon virtio_net i2c_piix4 i2c_core sg ext4 mbcache jbd2 virtio_blk sr_mod cdrom virtio_pci virtio_ring virtio pata_acpi ata_generic ata_piix dm_mirror dm_region_hash dm_log dm_mod [last unloaded: speedstep_lib]
Pid: 2544, comm: umount Tainted: G           ---------------  T 2.6.32-332.el6.x86_64 #1
Call Trace:
 [<ffffffff8106a167>] ? warn_slowpath_common+0x87/0xc0
 [<ffffffff8106a1ba>] ? warn_slowpath_null+0x1a/0x20
 [<ffffffff811b1102>] ? mark_buffer_dirty+0x82/0xa0
 [<ffffffffa01ea6d3>] ? ext2_sync_fs+0x43/0xb0 [ext2]
 [<ffffffff811ad2e3>] ? __sync_filesystem+0x53/0x90
 [<ffffffff811ad50a>] ? sync_filesystem+0x3a/0x70
 [<ffffffff8117e9d7>] ? generic_shutdown_super+0x27/0xe0
 [<ffffffff8117eac1>] ? kill_block_super+0x31/0x50
 [<ffffffff8117fc20>] ? deactivate_super+0x70/0x90
 [<ffffffff8119d1bf>] ? mntput_no_expire+0xbf/0x110
 [<ffffffff8119dc2b>] ? sys_umount+0x7b/0x3a0
 [<ffffffff8100b072>] ? system_call_fastpath+0x16/0x1b
---[ end trace 8906a340f9a45adf ]---
Buffer I/O error on device dm-5, logical block 1
lost page write due to I/O error on dm-5

Version-Release number of selected component (if applicable):
kernel-2.6.32-332.el6.x86_64

How reproducible:


Steps to Reproduce:
1. build lvm2 (http://sourceware.org/lvm2/)
2. enter test subdir
3. make check_local T=snapshot-autoumount
  
Actual results:


Expected results:


Additional info:
Comment 2 Mike Snitzer 2012-11-09 10:05:59 EST
(In reply to comment #0)
> Description of problem:
> 
> Execution of lvm2 test suite  (shell/snapshot-autoumount-dmeventd.sh)
> triggers this kernel Warning message:
> 
> evice-mapper: snapshots: Invalidating snapshot: Unable to allocate exception.
> Buffer I/O error on device dm-5, logical block 1

DM is causing the IO to get errored due to the snapshot being invalidated (begs the question.. are you running this on a machine with very little memory?)

I'll defer to the FS team on the actual warning.
Comment 3 Eric Sandeen 2012-11-09 11:24:28 EST
The buffer.c warning is more or less the same issue as in bug #679930 I think.  ext2 gets an IO failure, and then handling the dirty data becomes an issue.

(I'm amazed that people test ext2 so much ... !)
Comment 4 Eric Sandeen 2012-11-09 11:32:31 EST

*** This bug has been marked as a duplicate of bug 679930 ***

Note You need to log in before you can comment on or make changes to this bug.