Bug 866976 - seam-gen generated war project richfaces warnings in logs "Problem parsing 'theme.ecss' resource: Error in attribute selector."
seam-gen generated war project richfaces warnings in logs "Problem parsing 't...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 09:16 EDT by Marek Schmidt
Modified: 2012-11-30 10:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-10-16 09:16:32 EDT
Description of problem:

Requesting the home page of a seam-gen generated WAR project displays the following warnings in the EAP6.0.0 logs:

15:05:16,744 WARNING [org.richfaces.log.Resource] (http-/127.0.0.1:8080-3) Problem parsing 'theme.ecss' resource: Error in attribute selector. Invalid token "*". Was expecting one of: <S>, "=", "]", "~=", "|=".
15:05:16,744 WARNING [org.richfaces.log.Resource] (http-/127.0.0.1:8080-3) Problem parsing 'theme.ecss' resource: Ignoring the whole rule.
15:05:16,745 WARNING [org.richfaces.log.Resource] (http-/127.0.0.1:8080-3) Problem parsing 'theme.ecss' resource: Error in attribute selector. Invalid token "*". Was expecting one of: <S>, "=", "]", "~=", "|=".
15:05:16,745 WARNING [org.richfaces.log.Resource] (http-/127.0.0.1:8080-3) Problem parsing 'theme.ecss' resource: Ignoring the whole rule.
15:05:16,747 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.html.images.SliderFieldGradient.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,748 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.html.images.SliderFieldGradient.
15:05:16,748 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.html.images.SliderFieldGradient.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,748 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.html.images.SliderFieldGradient.
15:05:16,749 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.html.GradientA.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,749 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.html.GradientA.
15:05:16,750 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.images.TabGradientB.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,750 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.images.TabGradientB.
15:05:16,751 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.html.images.ComboBoxArrowImageDisable.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,751 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.html.images.ComboBoxArrowImageDisable.
15:05:16,752 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (http-/127.0.0.1:8080-3) JSF1091: No mime type could be found for file org.richfaces.renderkit.html.images.ComboBoxButtonPressGradient.  To resolve this, add a mime-type mapping to the applications web.xml.
15:05:16,752 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (http-/127.0.0.1:8080-3) JSF1064: Unable to find or serve resource, org.richfaces.renderkit.html.images.ComboBoxButtonPressGradient.

The problematic resource seems to be the theme.ecss, which translates into something similar to the following in the generated HTML:

<link type="text/css" rel="stylesheet" href="/myproject/rfRes/theme.ecss.seam?db=eAHb1WuhCAAFJAGh" />


Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1

How reproducible:
Always

Steps to Reproduce:
1. Use seam-gen to generate a default WAR project
2. explode the project into EAP6.0.0
3. Clear cache in Firefox (as it won't load the problematic CSS resource if it already have it in cache)
4. Open http://127.0.0.1:8080/myproject/home.seam
  
Actual results:
The aforementioned warnings appear in the logs.

Expected results:
No errors or warnings should appear in the logs
Comment 1 Marek Novotny 2012-10-31 10:40:38 EDT
There are some undocumented issues for migration from xcss to ecss (Richfaces 3 to Richfaces 4). These warnings are symptoms for missing (renamed/removed) static resources in richfaces 4.2.x UI components.

I removed all not clear replacements and everywhere I can recognize similar existing static resource images so some are fixed.
Comment 4 Karel Piwko 2012-11-30 10:34:08 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.