Bug 866984 - Please enable CONFIG_TCM_VHOST in 3.6 kernels
Please enable CONFIG_TCM_VHOST in 3.6 kernels
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On: 866981
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 09:33 EDT by Julio Entrena Perez
Modified: 2012-12-20 10:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 866981
Environment:
Last Closed: 2012-12-20 10:36:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julio Entrena Perez 2012-10-16 09:33:54 EDT
Applies to Fedora 17 too.

+++ This bug was initially created as a clone of Bug #866981 +++

> Description of problem:
tcm_vhost is not enabled in 3.6 kernels.

> Version-Release number of selected component (if applicable):
kernel 3.6.1-1.fc17.

> How reproducible:
Always.

> Steps to Reproduce:
1. $ grep -r CONFIG_TCM_VHOST /usr/src/kernels/3.6.1-1.fc17.x86_64/.config 
  
> Actual results:
# CONFIG_TCM_VHOST is not set

> Expected results:
CONFIG_TCM_VHOST=m

> Additional info:
http://lwn.net/Articles/508788/
Comment 1 Josh Boyer 2012-10-17 10:59:54 EDT
For future reference, it would be good if you actually said why you want a module enabled.  There's nothing at all about why this should be enabled in the report.

I did it anyway since Justin already did a similar commit for F18.
Comment 2 Julio Entrena Perez 2012-10-17 11:14:43 EDT
(In reply to comment #1)
> For future reference, it would be good if you actually said why you want a
> module enabled.  There's nothing at all about why this should be enabled in
> the report.

Sorry Josh, motivation is to be able to use virtio-scsi with the tcm_vhost fabric to allow SCSI commands sent from KVM guests to reach the backing store.
http://wiki.qemu.org/Features/VirtioSCSI/TCM_Overview

For example, using virtio-scsi with tcm_vhost and target_core_pscsi (SCSI pass-through backing store) allows KVM guests to send TRIM commands to the underlying device (e.g. a SSD drive).
Comment 3 Josh Boyer 2012-10-17 11:29:02 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > For future reference, it would be good if you actually said why you want a
> > module enabled.  There's nothing at all about why this should be enabled in
> > the report.
> 
> Sorry Josh, motivation is to be able to use virtio-scsi with the tcm_vhost
> fabric to allow SCSI commands sent from KVM guests to reach the backing
> store.
> http://wiki.qemu.org/Features/VirtioSCSI/TCM_Overview
> 
> For example, using virtio-scsi with tcm_vhost and target_core_pscsi (SCSI
> pass-through backing store) allows KVM guests to send TRIM commands to the
> underlying device (e.g. a SSD drive).

Awesome.  Thanks for the quick info!  It's always good to have reasoning documented for why something was enabled.
Comment 4 Fedora Update System 2012-10-22 14:39:03 EDT
kernel-3.6.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.3-1.fc17
Comment 5 Fedora Update System 2012-10-22 21:54:16 EDT
Package kernel-3.6.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.3-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16669/kernel-3.6.3-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:36:22 EST
kernel-3.6.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.