Bug 867016 - rsyslog gssapi functionality gets broken with InputGSSServerPermitPlainTCP
rsyslog gssapi functionality gets broken with InputGSSServerPermitPlainTCP
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rsyslog (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Tomas Heinrich
Karel Srot
:
Depends On:
Blocks: 1070830 1075802 1159820 1172231
  Show dependency treegraph
 
Reported: 2012-10-16 10:45 EDT by Karel Srot
Modified: 2016-06-02 15:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1085379 1289184 (view as bug list)
Environment:
Last Closed: 2016-06-02 15:37:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A little bit more detailed log from the testing (17.48 KB, application/octet-stream)
2012-10-16 10:54 EDT, Karel Srot
no flags Details

  None (edit)
Description Karel Srot 2012-10-16 10:45:27 EDT
Description of problem:

rsyslogd crashes or hangs or looses log messages in various configurations.
This is a bit complex problem.

rsyslogd can be configured using InputGSSServerPermitPlainTCP on to accept both gssapi and tcp/plain messages. I have tested following 6 scenarios:

1) server accepts gssapi only && client sends gssapi only:
works fine except AVC denials reported as bug 867001

2) server accepts gssapi only && client sends tcp/plain only:
rsyslog crashes, this is reported as bug 862517.

3) server accepts gssapi only && clients sends both gssapi and tcp/plain:
again, rsyslog crashes 

4) server accepts both gssapi and tcp/plain, client sends gssapi messages:
gssapi messages are not delivered

5) server accepts both gssapi and tcp/plain, client sends plain messages only:
plaintext only messages can be delivered with $InputGSSServerPermitPlainTCP on, but the log is flooded with netstream session errors

6)  server accepts both gssapi and tcp/plain, client sends both gssapi and plain messages
nor tcp nor gssapi messages are delivered because of issues in client-server
communication. But tcp/plain messages sent by netcat were delivered.


Version-Release number of selected component (if applicable):
rsyslog-5.8.10-2.el6

How reproducible:
always

Steps to Reproduce:
It is pretty complicated. I started with http://www.rsyslog.com/doc/gssapi.html
but I would recommend to contact me.
Comment 1 Karel Srot 2012-10-16 10:51:39 EDT
I have also tested it with rsyslog built with patch from bug 862517. 

1) server accepts gssapi only && client sends gssapi only:
messages delivered but I got a netstream session error at the end (could be related to something else)

2) server accepts gssapi only && client sends tcp/plain only:
rsyslog client-server connection got stucked

3) server accepts gssapi only && clients sends both gssapi and tcp/plain:
again, rsyslog client-server connection got stucked

4) server accepts both gssapi and tcp/plain, client sends gssapi messages:
gssapi message wasn't delivered, several netstream session errors

5) server accepts both gssapi and tcp/plain, client sends plain messages only:
plaintext only messages can be delivered with $InputGSSServerPermitPlainTCP on, but the log is flooded with netstream session errors

6)  server accepts both gssapi and tcp/plain, client sends both gssapi and plain messages
nor tcp nor gssapi messages are delivered because of issues in client-server
communication. But tcp/plain messages sent by netcat were delivered.
Several netstream session errors.
Comment 2 Karel Srot 2012-10-16 10:54:13 EDT
Created attachment 628201 [details]
A little bit more detailed log from the testing
Comment 5 RHEL Product and Program Management 2012-12-16 01:47:13 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 Tomas Heinrich 2013-08-20 12:26:58 EDT
This isn't going to make it this devel-cycle. Postponing to 6.6.

Note You need to log in before you can comment on or make changes to this bug.