Bug 867100 - Backport upstream commit f26d2e5f99ff402910407165ae228025991151b9 to fix unittests
Backport upstream commit f26d2e5f99ff402910407165ae228025991151b9 to fix unit...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openstack-swift (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Derek Higgins
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 14:56 EDT by Peter Portante
Modified: 2013-03-22 21:01 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 21:01:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Portante 2012-10-16 14:56:45 EDT
Description of problem:

Unit tests failing on F17 and later with the following problem:

Traceback (most recent call last):
  File "/home/pportant/Documents/RHS/OpenStack/Swift/tree/test/unit/common/middleware/test_swift3.py", line 478, in test_object_GET_Range
    resp = local_app(req.environ, local_app.app.do_start_response)
  File "/home/pportant/Documents/RHS/OpenStack/Swift/tree/swift/common/middleware/swift3.py", line 479, in __call__
    res = getattr(controller, req.method)(env, start_response)
  File "/home/pportant/Documents/RHS/OpenStack/Swift/tree/swift/common/middleware/swift3.py", line 378, in GET
    return self.GETorHEAD(env, start_response)
  File "/home/pportant/Documents/RHS/OpenStack/Swift/tree/swift/common/middleware/swift3.py", line 339, in GETorHEAD
    app_iter = self.app(env, self.do_start_response)
  File "/home/pportant/Documents/RHS/OpenStack/Swift/tree/test/unit/common/middleware/test_swift3.py", line 151, in __call__
    return iter.pop()
AttributeError: 'AppIterRange' object has no attribute 'pop'


Version-Release number of selected component (if applicable):

F17 and later

How reproducible:

Every time.

Steps to Reproduce:
1. checkout openstack swift
2. run unit tests (./.unitests)
3. observe problem of one failed test, which prevents others from running
  
Actual results:

Unit tests fail to run in the test_swift3 tests for F17

Expected results:

All unit tests run and pass.

Additional info:

Upstream commit link is:
https://github.com/openstack/swift/commit/f26d2e5f99ff402910407165ae228025991151b9
Comment 1 Peter Portante 2012-10-16 15:13:56 EDT
You can find a version of this fix already backported against 1.4.8 at:

https://github.com/portante/swift/commit/14dffe66b774eaaf6f35fe0a9ce3152b7886d205

if this helps.
Comment 2 Alan Pevec 2012-10-16 15:24:13 EDT
Any reason not to move to Swift 1.7.4 in F18 ?

swift3 (S3 emulation) was removed[1] in Swift 1.5.0 so backporting related unit test fixes doesn't feel like a high priority.


[1] moved to a stand-alone project https://github.com/fujita/swift3
Comment 3 Peter Portante 2012-10-16 17:19:05 EDT
I had thought that F18 was already 1.7.4, if it isn't then I agree we should move F18 to 1.7.4.

For F17 though, I think it is worth while to make sure the unit tests still run so that as other patches are applied, this whole suite of tests is not missed.

While I agree it is not a high priority, it still seems worth the effort, and since the patch is trivial, we apparently gain a lot (successful unit tests runs) by taking it.
Comment 6 Pete Zaitcev 2013-03-22 21:01:31 EDT
Fixed in openstack-swift-plugin-swift3-1.7-2.fc20, closing.

BTW, we now have other unit test failures in swift3 on Rawhide.
Need upstream work and possibly a separate bug.

Note You need to log in before you can comment on or make changes to this bug.