Bug 867136 - Crash when deleting a non-chat GOA account
Crash when deleting a non-chat GOA account
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: empathy (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
abrt_hash:92603020fbd1e9a57b203f2e13c...
:
Depends On:
Blocks: 1297830 1313485
  Show dependency treegraph
 
Reported: 2012-10-16 16:49 EDT by Matěj Cepl
Modified: 2016-05-19 05:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 05:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (4.01 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: environ (1.06 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: backtrace (22.01 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: cgroup (117 bytes, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: maps (20.33 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: dso_list (1.76 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: build_ids (1.72 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: var_log_messages (874 bytes, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: open_fds (439 bytes, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details
File: proc_pid_status (1.06 KB, text/plain)
2012-10-16 16:49 EDT, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 704469 None None None 2016-04-14 12:31 EDT

  None (edit)
Description Matěj Cepl 2012-10-16 16:49:15 EDT
Description of problem:
Probably when killed all telepathy-* programs with pkill -f telepathy

Version-Release number of selected component:
telepathy-mission-control-5.14.0-1.el7

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.15
backtrace_rating: 4
cmdline:        /usr/libexec/mission-control-5
crash_function: g_str_hash
kernel:         3.6.0-0.28.el7.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 g_str_hash at ghash.c:1730
: #1 g_hash_table_lookup_node at ghash.c:401
: #2 g_hash_table_lookup at ghash.c:1074
: #3 deleted_cb
: #7 g_signal_emit_by_name at gsignal.c:3393
: #8 _account_removed_cb at mcp-account-manager-goa.c:296
: #9 g_cclosure_marshal_VOID__OBJECTv at gmarshal.c:1312
: #10 _g_closure_invoke_va at gclosure.c:840
: #16 g_signal_emit_by_name at gsignal.c:3393
: #17 on_notify_g_name_owner at gdbusobjectmanagerclient.c:1252
Comment 1 Matěj Cepl 2012-10-16 16:49:18 EDT
Created attachment 628389 [details]
File: core_backtrace
Comment 2 Matěj Cepl 2012-10-16 16:49:20 EDT
Created attachment 628390 [details]
File: environ
Comment 3 Matěj Cepl 2012-10-16 16:49:22 EDT
Created attachment 628391 [details]
File: backtrace
Comment 4 Matěj Cepl 2012-10-16 16:49:24 EDT
Created attachment 628392 [details]
File: limits
Comment 5 Matěj Cepl 2012-10-16 16:49:26 EDT
Created attachment 628393 [details]
File: cgroup
Comment 6 Matěj Cepl 2012-10-16 16:49:28 EDT
Created attachment 628394 [details]
File: maps
Comment 7 Matěj Cepl 2012-10-16 16:49:30 EDT
Created attachment 628395 [details]
File: dso_list
Comment 8 Matěj Cepl 2012-10-16 16:49:32 EDT
Created attachment 628396 [details]
File: build_ids
Comment 9 Matěj Cepl 2012-10-16 16:49:34 EDT
Created attachment 628397 [details]
File: var_log_messages
Comment 10 Matěj Cepl 2012-10-16 16:49:36 EDT
Created attachment 628398 [details]
File: open_fds
Comment 11 Matěj Cepl 2012-10-16 16:49:38 EDT
Created attachment 628399 [details]
File: proc_pid_status
Comment 14 RHEL Product and Program Management 2014-03-22 03:04:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 17 Debarshi Ray 2016-04-14 12:31:05 EDT
Even though /usr/libexec/mission-control-5, it is due to the telepathy-mission-control plugin shipped by empathy to integrate with gnome-online-accounts.
Comment 18 Debarshi Ray 2016-04-14 12:34:49 EDT
This was fixed during the rebase in RHEL 7.2 (bug 1174588).
Comment 19 Debarshi Ray 2016-04-14 12:37:49 EDT
Sorry, this was already fixed in rhel-7.0 because the patch was part of the upstream 3.8.4 release.
Comment 21 Matěj Cepl 2016-05-19 05:44:20 EDT
This seems like fixed.

Note You need to log in before you can comment on or make changes to this bug.