Bug 867139 - Evolution has a problem to parse attached email
Evolution has a problem to parse attached email
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 16:52 EDT by Matěj Cepl
Modified: 2012-10-17 06:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: evolution-3.6.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 06:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message in question (830.48 KB, message/rfc822)
2012-10-16 16:52 EDT, Matěj Cepl
no flags Details
screenshot of the Evolution in the given state (193.80 KB, image/png)
2012-10-16 16:53 EDT, Matěj Cepl
no flags Details
~/.cache/gdm/session.log (21.78 KB, text/plain)
2012-10-16 16:54 EDT, Matěj Cepl
no flags Details
backtrace of evolution when the thing happened (14.04 KB, text/plain)
2012-10-16 16:57 EDT, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 686278 None None None 2012-10-17 04:56:55 EDT

  None (edit)
Description Matěj Cepl 2012-10-16 16:52:59 EDT
Created attachment 628401 [details]
message in question

Description of problem:
Evolution when it gets to the attached message just stops on the attached message, it gets to 100%CPU on one CPU (fortunately, I have more of them) and that's it.

Version-Release number of selected component (if applicable):
evolution-3.6.0-1.el7.x86_64

How reproducible:
this message has never been succesfully parsed even though I have killed and restarted evolution couple of times (including removing whole cache of the folder where the message is located ... it's on IMAP, against Zarafa server).

Steps to Reproduce:
1.see attached evidence
2.
3.
  
Actual results:
see above

Expected results:
message should be pretty quickly parsed and I go on with my life.

Additional info:
Comment 1 Matěj Cepl 2012-10-16 16:53:28 EDT
Created attachment 628402 [details]
screenshot of the Evolution in the given state
Comment 2 Matěj Cepl 2012-10-16 16:54:40 EDT
Created attachment 628405 [details]
~/.cache/gdm/session.log
Comment 3 Matěj Cepl 2012-10-16 16:57:34 EDT
Created attachment 628406 [details]
backtrace of evolution when the thing happened
Comment 4 Milan Crha 2012-10-17 02:52:47 EDT
Thanks for a bug report. I can reproduce it with your message too.
Comment 5 Milan Crha 2012-10-17 04:56:55 EDT
I filled this upstream [1] for a better reference, and took your message, stripped from it private information, and attached it there for testing too.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=686278
Comment 6 Milan Crha 2012-10-17 06:11:51 EDT
Fixed within upstream bug for 3.6.2. I thought it's because multipart/mixed, but it turned out as a problem with prefer-plain plugin, which broke the parts list (probably because text/plain part was after text/html, while it should be the fist part).

Note You need to log in before you can comment on or make changes to this bug.