Bug 867173 - gnome-shell segfault after opening long combobox in gtk3 apps
gnome-shell segfault after opening long combobox in gtk3 apps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cogl (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 20:55 EDT by Iván Jiménez
Modified: 2012-10-18 23:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 23:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Iván Jiménez 2012-10-16 20:55:27 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.6+ (KHTML, like Gecko) Chromium/17.0.963.56 Chrome/17.0.963.56 Safari/537.6+ Epiphany/3.6.0
Build Identifier: 

gnome-shell segfaults after opening a long combobox in gtk3 applications, for example when using the currency selector in gcalctool. After the crash, /var/log/messages contains:

Oct 16 19:14:52 mini kernel: [  157.089202] gnome-shell[1425]: segfault at 0 ip 00000030eea238a0 sp 00007fff7e604288 error 4 in libcogl.so.11.0.2[30eea00000+8e000]

This is a netbook with a 1024x600 screen.


Reproducible: Always

Steps to Reproduce:
1.open gcalctool
2. click the currency selector combobox
3.
Actual Results:  
gnome-shell crash


I've seen the same crash after clicking on a long combobox in epiphany
Comment 1 Iván Jiménez 2012-10-16 21:18:14 EDT
The relevant versions of packages are:
gnome-shell-3.6.0-1.fc18.x86_64
gtk3-3.6.0-1.fc18.x86_64
cogl-1.12.0-1.fc18.x86_64
clutter-1.12.0-2.fc18.x86_64
Comment 2 Peter Robinson 2012-10-17 08:31:38 EDT
Please report via abrt and update this with the bug report so we have a full backtrace
Comment 3 Iván Jiménez 2012-10-17 15:43:09 EDT
(In reply to comment #2)
> Please report via abrt and update this with the bug report so we have a full
> backtrace

I can't report via abrt because it doesn't catch the segfault. After the crash, the fail whale dialog appears saying that something went wrong and could not be recovered, offering a button to logout. Also, it doesn't show as an unsent report in abrt afterwards.

Any idea how to make it appears in abrt or how to manually generate the backtrace? (arbtd.service is running)
Comment 4 Matthias Clasen 2012-10-18 23:40:05 EDT
This was fixed in 3.6.1, I believe.

Note You need to log in before you can comment on or make changes to this bug.