Bug 867242 - Doesn't have meaningful error message when trying to idle nonexistent UUID
Doesn't have meaningful error message when trying to idle nonexistent UUID
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 02:33 EDT by Wei Sun
Modified: 2015-05-14 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-10-17 02:33:27 EDT
Description of problem:

Log in an instance,run "rhc-idler -u " with nonexistent UUID,don't show meaningful error message,only list the command's usage.Should give a prompt like "UUID does not exist".

Version-Release number of selected component (if applicable):
devenv_2340
rhc 0.99.7 on devenv_2340

How reproducible:
always

Steps to Reproduce:
1.Try to idle nonexistent UUID
  rhc-idler -u c2892

  [root@ip-10-42-103-131 ~]# rhc-idler -u c2892
Usage: /usr/bin/rhc-idler
  -u UUID       idles the app
  -l            list all idled apps
  -n            don't restart httpd

Actual results:

Expected results:
Give a meaningful error message

Additional info:
Comment 1 Rob Millner 2012-10-26 20:00:40 EDT
# oo-idler  -u blahblahblah
Unknown gear UUID: blahblahblah
Usage: ./oo-idler
  -u UUID       idles the app
  -l            list all idled apps
  -n            don't restart httpd


Added to pull request:
https://github.com/openshift/origin-server/pull/777
Comment 2 Xiaoli Tian 2012-10-28 22:50:02 EDT
> https://github.com/openshift/origin-server/pull/777

Move it to ON_QA since above pull request is merged
Comment 3 Wei Sun 2012-10-29 00:16:11 EDT
verified on devenv_2397

Step:
1.Try to idle nonexistent UUID
oo-idler -u $uuid

Result:
[root@ip-10-122-55-61 ~]# oo-idler -u test
Unknown gear UUID: test
Usage: /usr/bin/oo-idler
  -u UUID       idles the app
  -l            list all idled apps
  -n            don't restart httpd

Note You need to log in before you can comment on or make changes to this bug.