Bug 867252 - gluster volume remove-brick force does not work
gluster volume remove-brick force does not work
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks: 867380
  Show dependency treegraph
 
Reported: 2012-10-17 03:05 EDT by Bala.FA
Modified: 2015-11-22 21:57 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 867380 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:09:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bala.FA 2012-10-17 03:05:22 EDT
Description of problem:
gluster volume remove-brick VOLUME BRICK force command doesn't remove the brick

Version-Release number of selected component (if applicable):
upstream master branch


How reproducible:


Steps to Reproduce:
1. gluster volume create test 192.168.122.2:/tmp/test-b1
2. gluster volume add-brick test 192.168.122.2:/tmp/test-b2
3. gluster volume remove-brick test 192.168.122.2:/tmp/test-b2 force

Actual results:
brick 192.168.122.2:/tmp/test-b2 appears in 'gluster volume info test'


Expected results:
brick 192.168.122.2:/tmp/test-b2 should be removed


Additional info:
Comment 1 Amar Tumballi 2012-10-23 13:15:52 EDT
posted patch with the regression test cases @ http://review.gluster.org/4127
Comment 2 krishnan parthasarathi 2012-10-23 22:56:25 EDT
Bala,

What was the hostname/ip of the machine from which the gluster CLI was invoked?
If the hostname/IP was not 192.168.122.2, then could you mark this bug as duplicate of 866916.
Comment 3 krishnan parthasarathi 2012-10-23 22:59:00 EDT
This bug is __not__ a duplicate of 866916. I will send out the patch for 866916 and update that bug with the reason.
Comment 4 Vijay Bellur 2012-10-24 12:49:41 EDT
CHANGE: http://review.gluster.org/4127 (glusterd: fix for remove-brick on just created/stopped volumes) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Bala.FA 2012-10-25 21:04:07 EDT
(In reply to comment #3)
> This bug is __not__ a duplicate of 866916. I will send out the patch for
> 866916 and update that bug with the reason.

FYI, the command was executed on 192.168.122.2 only.

Note You need to log in before you can comment on or make changes to this bug.