Bug 867284 - can not change Chinese characters style
can not change Chinese characters style
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elad Alfassa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 04:40 EDT by lnie
Modified: 2012-10-18 11:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 11:16:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lnie 2012-10-17 04:40:53 EDT
Description of problem:
I type some chinese characters,and try to change the style,using the"format"tool on the tool bar.but failed.actually, the chinese characters's styles(italic,bold..) can not be changed as it dose in f15

Version-Release number of selected component (if applicable):

f18
How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Elad Alfassa 2012-10-17 05:11:46 EDT
gnome-documents doesn't have an option to edit documents and doesn't have a format toolbar.

Maybe you wanted to file this against libreoffice?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 lnie 2012-10-17 06:05:23 EDT
(In reply to comment #1)
> gnome-documents doesn't have an option to edit documents and doesn't have a
> format toolbar.
> 
> Maybe you wanted to file this against libreoffice?
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

Er,sorry for my disturb. I don't know where I should file,but the problem is here.may be the gnome can adopt other version of libreoffice to avoid this problem .can you tell me what should I do to find the right person to fix this problem? sorry for my disturb again.
Comment 3 Elad Alfassa 2012-10-17 06:17:35 EDT
Moving this to libreoffice. This has nothing to do with GNOME or gnome-documents.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 David Tardon 2012-10-17 06:51:06 EDT
I pasted a couple of characters from http://www.google.cn/ into a new writer document. Then I selected the pasted text, set it to bold, italic and changed its size, without any visible problem.

Could you write exactly what you did, step by step? Or even attach a sample document where this does not work?
Comment 5 lnie 2012-10-17 22:40:45 EDT
(In reply to comment #4)
> I pasted a couple of characters from http://www.google.cn/ into a new writer
> document. Then I selected the pasted text, set it to bold, italic and
> changed its size, without any visible problem.
> 
> Could you write exactly what you did, step by step? Or even attach a sample
> document where this does not work?

yeah,I have tried just now,I can change the style by "click right button"+"select style".I suppose that you changed the style this way,right?yesterday I happened to change some English characters by the " format" key (on the top of libreoffice writer)+"characters".so I tried change the chinese character in that way but failed.then I tried it  in f15,successed.Anyway,the users can change the character style,the problem is not so serious then.
Finally, thanks for your kindly reply.
Comment 6 Caolan McNamara 2012-10-18 11:16:09 EDT
Pasted in 光子是传递电磁相互作用的基本粒子 to writer, selected the lot, clicked the "bold" and "italic" buttons on the toolbar and the text is bold and italic. No need to right click and select from those menus, though they work as well.

If you use format character, then only "western" text is shown there unless tools->options->language settings->languages-> Asian/Complex is enabled. They are auto-enabled if launched from locale considered to be Asian or Complex.

Note You need to log in before you can comment on or make changes to this bug.