Bug 867322 - Better to change the status of mongodb and mysql from "NEW" to "STARTED" when they are embeded to scalable application.
Better to change the status of mongodb and mysql from "NEW" to "STARTED" when...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 06:16 EDT by Yujie Zhang
Modified: 2015-05-14 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-10-17 06:16:51 EDT
Description of problem:

After I embeded mongodb and mysql to scalable application, the status of these two cartridges are "NEW", for the cartridges are running, suggest to change the status to "STARTED", just the same like postgresql.

Version-Release number of selected component (if applicable):
devenv_2340

How reproducible:always


Steps to Reproduce:
1.Create a scalable application
2.Embed mongodb and mysql
3.Check the status of these two cartridges
  
Actual results:

The status of mongodb and mysql is "NEW".

Expected results:

Better to change the status to "STARTED" to make it consistent with postgresql.

Additional info:
Comment 1 Rob Millner 2012-10-26 19:41:19 EDT
Added to https://github.com/openshift/origin-server/pull/777
Comment 2 Xiaoli Tian 2012-10-28 22:38:19 EDT
(In reply to comment #1)
> Added to https://github.com/openshift/origin-server/pull/777

Move it to ON_QA since above pull request is merged.
Comment 3 Yujie Zhang 2012-10-29 01:11:57 EDT
(In reply to comment #1)
Tested this issue on devenv_2397, it has been fixed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.