Bug 867337 - STP seems to be ignored in ifcfg files
STP seems to be ignored in ifcfg files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 06:44 EDT by Tomas Pelka
Modified: 2013-02-28 06:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 06:55:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2012-10-17 06:44:50 EDT
Description of problem:
STP seems to be ignored in ifcfg config files.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-39.el6

How reproducible:
100%

Steps to Reproduce:
1. configure bridge

cat /etc/sysconfig/network-scripts/ifcfg-Auto_Ethernet 
TYPE=Ethernet
NAME="br test"
ONBOOT=yes
BRIDGE=br0
IPV6INIT=no
USERCTL=no
HWADDR=00:1E:4F:DA:D7:64
UUID=02e004fc-e5cc-15ce-4b2a-a0dfe7a2865f

cat /etc/sysconfig/network-scripts/ifcfg-br0 
DEVICE=br0
TYPE=Bridge
BOOTPROTO=dhcp
ONBOOT=yes
STP=on

2. reconnect profile
3. brctl show br0


Actual results:
bridge name	bridge id		STP enabled	interfaces
br0		8000.001e4fdad764	no		eth0


Expected results:
I would guess that STP should be enabled 

Additional info:
Comment 1 RHEL Product and Program Management 2012-12-14 03:44:20 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 Dan Williams 2013-02-25 17:54:27 EST
Can you retest with RHEL 6.4?  It should be working correctly there.
Comment 3 Tomas Pelka 2013-02-28 06:55:40 EST
You are right Dan, it is working for me CLOSING as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.