Bug 867343 - volume sync fails
volume sync fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-server (Show other bugs)
2.0
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
SATHEESARAN
:
Depends On: 861481
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 06:58 EDT by Vidya Sakar
Modified: 2015-11-03 18:04 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 861481
Environment:
Last Closed: 2013-09-23 18:39:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-10-17 06:58:45 EDT
+++ This bug was initially created as a clone of Bug #861481 +++

Description of problem:
When calling "gluster volume sync all", it's always "unsuccessful". All glusterd's:
[2012-09-28 12:05:35.830791] I [glusterd-handler.c:497:glusterd_handle_cluster_lock] 0-glusterd: Received LOCK from uuid: fcac92e9-b7c5-440a-bac0-8fb6dfe4b899
[2012-09-28 12:05:35.830849] I [glusterd-utils.c:285:glusterd_lock] 0-glusterd: Cluster lock held by fcac92e9-b7c5-440a-bac0-8fb6dfe4b899
[2012-09-28 12:05:35.830886] I [glusterd-handler.c:1315:glusterd_op_lock_send_resp] 0-glusterd: Responded, ret: 0
[2012-09-28 12:05:35.831385] I [glusterd-handler.c:1359:glusterd_handle_cluster_unlock] 0-glusterd: Received UNLOCK from uuid: fcac92e9-b7c5-440a-bac0-8fb6dfe4b899
[2012-09-28 12:05:35.831432] I [glusterd-handler.c:1335:glusterd_op_unlock_send_resp] 0-glusterd: Responded to unlock, ret: 0

If I specify a server to sync from:
gluster volume sync all ewcs2
Volume ��� does not exist

ewcs2 does report the same log sequence.

Version-Release number of selected component (if applicable):
3.3.0

How reproducible:
always

Steps to Reproduce:
1. stop glusterd on a server
2. rm -rf /var/lib/glusterd/vols
3. start glusterd
4. gluster volume sync all
5. gluster volume sync $volname
6. gluster volume sync all $hostname
7. gluster volume sync $volname $hostname
  
Actual results:
None of them work

Expected results:
Any of them should work

Additional info:
Comment 1 Amar Tumballi 2012-11-29 05:14:21 EST
http://review.gluster.org/4188 (fixed for rhs-2.1.0, would need to backport it for 2.0.z).
Comment 2 Amar Tumballi 2012-12-26 04:14:11 EST
marking ON_QA for rhs-2.1.0 flag. Let us know which update of RHS.2.0.z do we need this fix.
Comment 3 SATHEESARAN 2013-01-03 03:54:17 EST
As per description, the 7th step of issuing volume sync command should be,
gluster volume sync $hostname $volumename
Comment 4 SATHEESARAN 2013-01-03 03:58:19 EST
Verified this bug with, glusterfs 3.4.0qa5, since qa6 is not yet available.
Comment 7 Scott Haines 2013-09-23 18:39:17 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 8 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.