Bug 867379 - volume info displays information about a brick that has already been removed
volume info displays information about a brick that has already been removed
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
:
Depends On: 866916
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:55 EDT by Vidya Sakar
Modified: 2013-12-18 19:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 866916
Environment:
Last Closed: 2012-10-18 02:07:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-10-17 07:55:59 EDT
+++ This bug was initially created as a clone of Bug #866916 +++

Description of problem:
Volume info command continues to display information about a brick even after its removal.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.In a two-machine cluster, create a volume with two bricks, one on each machine (say B1 on M1 and B2 on M2).
2.Execute remove-brick on M1 to remove the brick on M2 (i.e., B2).
3.Do volume info on M1.
  
Actual results:

Volume info displays information about B2, even after its removal.

Expected results:

Volume info should only display information about B1.

Additional info:

[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
----------------------------------------------------------
[root@kd glusterfs]# gluster volume remove-brick xyz 192.168.122.250:/home/xyzab start
volume remove-brick: success
---------------------------------------------------------
[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
----------------------------------------------------------
[root@kd glusterfs]# gluster volume remove-brick xyz 192.168.122.250:/home/xyzab commit
volume remove-brick: success
---------------------------------------------------------
[root@kd glusterfs]# gluster volume info xyz
 
Volume Name: xyz
Type: Distribute
Volume ID: d336401f-ecb2-428b-8a4c-dabfd8b1851f
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/export2/xyza
Brick2: 192.168.122.250:/home/xyzab
Comment 1 krishnan parthasarathi 2012-10-18 02:07:56 EDT
This bug is not applicable to RHS-2.0. It is only seen on master since http://review.gluster.org/4057 commit.

Note You need to log in before you can comment on or make changes to this bug.