Bug 867414 - NoSuchGroup: gnome-desktop
NoSuchGroup: gnome-desktop
Status: CLOSED DUPLICATE of bug 867605
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:846d8c62c8e7a7851933137add0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 09:17 EDT by Eric Paris
Modified: 2013-01-09 21:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 13:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (272.77 KB, text/plain)
2012-10-17 09:17 EDT, Eric Paris
no flags Details
File: product (6 bytes, text/plain)
2012-10-17 09:17 EDT, Eric Paris
no flags Details
File: type (9 bytes, text/plain)
2012-10-17 09:18 EDT, Eric Paris
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-17 09:18 EDT, Eric Paris
no flags Details
File: storage.log (80.70 KB, text/plain)
2012-10-17 09:18 EDT, Eric Paris
no flags Details

  None (edit)
Description Eric Paris 2012-10-17 09:17:53 EDT
Description of problem:
set up a custom repo, told it not to automatically use updates, tried to click the package screen, boom...

Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 791, in environmentHasOption
:    raise NoSuchGroup(environmentid)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 231, in refreshAddons
:    if self.payload.environmentHasOption(self.environment, grp) or (self.payload._isGroupVisible(grp) and self.payload._groupHasInstallableMembers(grp)):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 222, in refresh
:    self.refreshAddons()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 90, in _runSpoke
:    action.refresh()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 323, in _on_spoke_clicked
:    self._runSpoke(spoke)
:NoSuchGroup: gnome-desktop
Comment 1 Eric Paris 2012-10-17 09:17:55 EDT
Created attachment 628797 [details]
File: anaconda-tb
Comment 2 Eric Paris 2012-10-17 09:17:58 EDT
Created attachment 628798 [details]
File: product
Comment 3 Eric Paris 2012-10-17 09:18:00 EDT
Created attachment 628799 [details]
File: type
Comment 4 Eric Paris 2012-10-17 09:18:01 EDT
Created attachment 628800 [details]
File: ifcfg.log
Comment 5 Eric Paris 2012-10-17 09:18:03 EDT
Created attachment 628801 [details]
File: storage.log
Comment 6 Jesse Keating 2012-10-17 23:56:28 EDT
When you created your custom repo, did you create any sort of group metadata?  A comps file?

I ask because "gnome-desktop" doesn't exist anywhere in the anaconda code, so it's getting that from an environment, which would come from group metadata.  We shouldn't crash here, but there is some oddness going on.
Comment 7 Eric Paris 2012-10-18 10:22:21 EDT
I did not create the repo.  I ttied to just use the normal mirror, but had a dep problem. So i told it to use alt.stage.whatever and unchecked the get updates. Maybe that repo didn't have any groups but they got pulled from the original automatic attempt?  I'll look for the real address I pointed to when I have a pc.
Comment 8 Jesse Keating 2012-10-18 13:25:56 EDT
Yeah, I think this is actually an interaction between the two spokes issue.  Taking it as I took another like that.
Comment 9 Jesse Keating 2012-10-19 13:23:52 EDT
Closing this as a dupe of another with more info in it.

*** This bug has been marked as a duplicate of bug 867605 ***

Note You need to log in before you can comment on or make changes to this bug.