Bug 867428 - some graphic issues in non-English locales
some graphic issues in non-English locales
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Shahar Havivi
Yuko Katabami
ux
: i18n
: 870145 870252 871348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 09:46 EDT by Einav Cohen
Modified: 2012-12-04 15:07 EST (History)
14 users (show)

See Also:
Fixed In Version: si24.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen-shot: Login dialog in French locale (20.45 KB, image/png)
2012-10-17 11:35 EDT, Einav Cohen
no flags Details
Screen-shot: "New VM" dialog in French locale (51.27 KB, image/png)
2012-10-17 11:37 EDT, Einav Cohen
no flags Details
Screen-shot: "New Storage Domain" dialog in French locale (39.55 KB, image/png)
2012-10-17 11:39 EDT, Einav Cohen
no flags Details
Screen-capture: Login Page in Chinese locale (467.70 KB, video/ogg)
2012-10-17 11:55 EDT, Einav Cohen
no flags Details
Screenshot with issue (108.87 KB, image/png)
2012-11-11 21:22 EST, A S Alam
no flags Details

  None (edit)
Description Einav Cohen 2012-10-17 09:46:44 EDT
Description of problem:
There are several graphical issues when working with non-English locales (French, for example):
1. Login dialog is no aligned properly due to texts that are being broken into two lines.
2. New VM -> Host section: radio button on the top ("Host in any cluster" / "specific") are overlapping each other.
3. New Storage: Data-Center drop-down is pushed one line down.
4. New Storage (iscsi): CHAP user name and CHAP password fields are pushed one line down
5. Login dialog [Chinese]: locale drop-down is becoming 3 lines high, which doesn't look so bad, however the drop-down arrow is not clickable (need to click on one "row" higher in order to see the drop-down options)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Einav Cohen 2012-10-17 11:35:22 EDT
Created attachment 628884 [details]
Screen-shot: Login dialog in French locale

This screen-shot is to demonstrate issue 1 in the description.
Comment 2 Einav Cohen 2012-10-17 11:37:28 EDT
Created attachment 628885 [details]
Screen-shot: "New VM" dialog in French locale

This screen-shot demonstrates issue 2 in the description.
Comment 3 Einav Cohen 2012-10-17 11:39:43 EDT
Created attachment 628886 [details]
Screen-shot: "New Storage Domain" dialog in French locale

This screen-shot demonstrate issues 3 and 4 in the description.
Comment 4 Einav Cohen 2012-10-17 11:55:01 EDT
Created attachment 628906 [details]
Screen-capture: Login Page in Chinese locale

This screen-capture demonstrates issue 5 in the description.
Note that:
- the locale drop-down is 3-lines-high
- clicking the drop-down arrow does nothing
- clicking one "line" above the drop-down arrow opens the drop-down options.

This can simply be solved by making sure that the drop-down will be long enough to always contain the string in a single line.
Comment 5 Pavel Stehlik 2012-10-23 11:52:33 EDT
To be tested by the i18n/l10n team.
Comment 6 Yuko Katabami 2012-10-23 17:15:55 EDT
Hi Einav and Pavel,

I will be sharing the above issues with other translators who will be participating in the QA event. 
We will check each section and report you the result. 

Would you like us to add comments right here in BZ or in TCMS testcases?
Comment 8 Wei Liu 2012-10-24 19:27:18 EDT
I am testing for zh-CN. In Login page, when I choose locale as English, it always shows in 中文(简体)-中国, however, other locales work fine.

Leah
Comment 9 Yuko Katabami 2012-10-24 23:26:02 EDT
Please disregard the above comment by Leah - it is a separate issue and she has filed a new bug.
My instruction caused misunderstanding. 
Sorry about that.
Comment 10 Shahar Havivi 2012-10-28 10:34:40 EDT
*** Bug 870145 has been marked as a duplicate of this bug. ***
Comment 11 Shahar Havivi 2012-10-29 07:11:50 EDT
*** Bug 870252 has been marked as a duplicate of this bug. ***
Comment 12 Oved Ourfali 2012-10-30 10:20:30 EDT
*** Bug 871348 has been marked as a duplicate of this bug. ***
Comment 13 Oved Ourfali 2012-10-31 04:12:20 EDT
Commit: b6d5542cce31fa7df400a1fe305ff6aafbec1c4d

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=b6d5542cce31fa7df400a1fe305ff6aafbec1c4d
Comment 17 A S Alam 2012-11-11 21:22:26 EST
Created attachment 643159 [details]
Screenshot with issue
Comment 18 A S Alam 2012-11-11 21:57:07 EST
(In reply to comment #0)
> Description of problem:
> There are several graphical issues when working with non-English locales
> (French, for example):
> 1. Login dialog is no aligned properly due to texts that are being broken
> into two lines.


FIXED

> 3. New Storage: Data-Center drop-down is pushed one line down.
> 4. New Storage (iscsi): CHAP user name and CHAP password fields are pushed
> one line down

Not fixed


tested version: rhevm-3.1.0-26.el6ev.noarch (si24 build)
Comment 19 Shahar Havivi 2012-11-12 07:47:42 EST
regarding comment #18 issue #4
patch sent: http://gerrit.ovirt.org/#/c/9185/
Comment 20 Einav Cohen 2012-11-12 09:01:11 EST
(In reply to comment #18)
> (In reply to comment #0)
> > Description of problem:
> > There are several graphical issues when working with non-English locales
> > (French, for example):
> > 1. Login dialog is no aligned properly due to texts that are being broken
> > into two lines.
> 
> 
> FIXED
> 
> > 3. New Storage: Data-Center drop-down is pushed one line down.
> > 4. New Storage (iscsi): CHAP user name and CHAP password fields are pushed
> > one line down
> 
> Not fixed
> 
> 
> tested version: rhevm-3.1.0-26.el6ev.noarch (si24 build)

A S Alam: According to our tests and your screen-shot - attachment 643159 [details]:

#3 is also fixed in si24 - the Data Center line is not "breaking" anymore.

Only issue that needs to be fixed is #4.
Comment 24 A S Alam 2012-11-30 06:48:25 EST
> #3 is also fixed in si24 - the Data Center line is not "breaking" anymore.
> 
> Only issue that needs to be fixed is #4.

 #4 is Fixed and All issues are FIXED

Note You need to log in before you can comment on or make changes to this bug.