Bug 867451 - SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' accesses on the file /tmp/xauth.XXXXYSrWJi.
SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' ac...
Status: CLOSED DUPLICATE of bug 867449
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-10-17 10:30 EDT by Alison Lemes
Modified: 2012-12-16 14:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-16 14:44:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-17 10:30 EDT, Alison Lemes
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-17 10:30 EDT, Alison Lemes
no flags Details

  None (edit)
Description Alison Lemes 2012-10-17 10:30:12 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.1-1.fc17.x86_64

:SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' accesses on the file /tmp/xauth.XXXXYSrWJi.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If você acredita que o plugin-container deva ser permitido acesso de getattr em xauth.XXXXYSrWJi file  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:permitir este acesso agora executando:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:xauth_tmp_t:s0
:Target Objects                /tmp/xauth.XXXXYSrWJi [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner/plugin-container
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           xulrunner-16.0.1-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-153.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc17.x86_64 #1 SMP Wed Oct
:                              10 12:13:05 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-17 11:28:11 BRT
:Last Seen                     2012-10-17 11:28:11 BRT
:Local ID                      f508a137-fb8d-41e8-9017-b3ab8c8fad61
:Raw Audit Messages
:type=AVC msg=audit(1350484091.809:115): avc:  denied  { getattr } for  pid=4541 comm="plugin-containe" path="/tmp/xauth.XXXXYSrWJi" dev="dm-1" ino=59136 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:xauth_tmp_t:s0 tclass=file
:type=SYSCALL msg=audit(1350484091.809:115): arch=x86_64 syscall=fstat success=yes exit=0 a0=e a1=7fff26816720 a2=7fff26816720 a3=fffffffffffffe6c items=0 ppid=4450 pid=4541 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/xulrunner/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:Hash: plugin-containe,mozilla_plugin_t,xauth_tmp_t,file,getattr
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t xauth_tmp_t:file getattr;
:audit2allow -R
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t xauth_tmp_t:file getattr;
Comment 1 Alison Lemes 2012-10-17 10:30:15 EDT
Created attachment 628850 [details]
File: type
Comment 2 Alison Lemes 2012-10-17 10:30:20 EDT
Created attachment 628851 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-26 15:53:46 EDT
We have this in F18.
Comment 4 Miroslav Grepl 2012-12-16 14:44:53 EST

*** This bug has been marked as a duplicate of bug 867449 ***

Note You need to log in before you can comment on or make changes to this bug.