Bug 867460 - [abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x8e/0x90 [i915](): TAINTED G W
[abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x8...
Status: CLOSED DUPLICATE of bug 866472
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:375d0f18177c65fdb2010175b19...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:47 EDT by Martin Kyral
Modified: 2013-01-04 17:00 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 17:00:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2012-10-17 10:47:43 EDT
Description of problem:
http://fedoraproject.org/wiki/QA:Testcase_Power_Management_pm_hibernate

hibernation ok, after resume screen flickers

lspci -v (snippet)

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 1862
	Flags: bus master, fast devsel, latency 0, IRQ 46
	Memory at fd800000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at cc00 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: ASUSTeK Computer Inc. Device 1862
	Flags: bus master, fast devsel, latency 0
	Memory at fdd00000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3


Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        initrd=initrd0.img root=live:CDLABEL=PM-Test-Day-LiveCD rootfstype=auto ro rd.live.image   BOOT_IMAGE=vmlinuz0 
kernel:         3.6.1-1.fc18.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Taint on warning.

backtrace:
:WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x8e/0x90 [i915]()
:Hardware name: K50IJ               
:pipe B assertion failure (expected off, current on)
:Modules linked in: vfat fat fuse ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast bnep bluetooth ip6table_mangle ip6t_REJECT be2iscsi nf_conntrack_ipv6 iscsi_boot_sysfs nf_defrag_ipv6 bnx2i ip6table_filter cnic ip6_tables uio cxgb4i cxgb4 iptable_nat nf_nat cxgb3i cxgb3 mdio libcxgbi iptable_mangle ib_iser rdma_cm ib_addr iw_cm ib_cm nf_conntrack_ipv4 nf_defrag_ipv4 ib_sa ib_mad xt_conntrack nf_conntrack ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi arc4 ath9k snd_hda_codec_via ath9k_common ath9k_hw snd_hda_intel snd_hda_codec snd_hwdep ath snd_seq mac80211 snd_seq_device uvcvideo snd_pcm coretemp iTCO_wdt microcode videobuf2_vmalloc iTCO_vendor_support videobuf2_memops videobuf2_core videodev joydev serio_raw media lpc_ich mfd_core snd_page_alloc cfg80211 snd_timer snd soundcore asus_laptop sparse_keymap rfkill input_polldev uinput squashfs i915 i2c_algo_bit drm_kms_helper usb_storage drm atl1e i2c_core video
:Pid: 656, comm: Xorg Tainted: G        W    3.6.1-1.fc18.x86_64 #1
:Call Trace:
: [<ffffffff8105b83f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105b936>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa00be0be>] assert_pipe+0x8e/0x90 [i915]
: [<ffffffffa00c3769>] intel_crtc_disable+0x69/0xb0 [i915]
: [<ffffffffa006f825>] drm_helper_disable_unused_functions+0x115/0x170 [drm_kms_helper]
: [<ffffffffa0071142>] drm_crtc_helper_set_config+0x942/0xb00 [drm_kms_helper]
: [<ffffffff8104a698>] ? flush_tlb_page+0x48/0xb0
: [<ffffffff81048dec>] ? ptep_set_access_flags+0x6c/0x70
: [<ffffffff8161e2fd>] ? mutex_lock+0x1d/0x50
: [<ffffffffa0040a41>] drm_mode_setcrtc+0x121/0x590 [drm]
: [<ffffffffa00313c3>] drm_ioctl+0x4d3/0x580 [drm]
: [<ffffffffa0040920>] ? drm_mode_setplane+0x370/0x370 [drm]
: [<ffffffff811a1279>] do_vfs_ioctl+0x99/0x580
: [<ffffffff812817da>] ? inode_has_perm.isra.31.constprop.61+0x2a/0x30
: [<ffffffff81282c07>] ? file_has_perm+0x97/0xb0
: [<ffffffff811a17f9>] sys_ioctl+0x99/0xa0
: [<ffffffff81628a29>] system_call_fastpath+0x16/0x1b
Comment 1 Adam Jackson 2013-01-04 17:00:59 EST

*** This bug has been marked as a duplicate of bug 866472 ***

Note You need to log in before you can comment on or make changes to this bug.