Bug 867478 - [RHEVM] [backend] [Host Networking] host does not go non-operationl if required VLAN goes down
[RHEVM] [backend] [Host Networking] host does not go non-operationl if requir...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 All
unspecified Severity high
: ---
: ---
Assigned To: lpeer
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 11:22 EDT by Martin Pavlik
Modified: 2016-02-10 14:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-21 12:36:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (22.09 KB, application/x-gzip)
2012-10-17 11:22 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-10-17 11:22:26 EDT
Created attachment 628881 [details]
vdsm.log + engine.log

Description of problem:
host does not go non-operationl if required VLAN goes down

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-20.el6ev' 
vdsm-4.9.6-37.0.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. create required network with VLAN tag (e.g. VLAN2222, with tag 2222)
2. ssh to the host and run ifdown VLAN2222 && ifdown em2.2222

  
Actual results:
host stays operational despite required network is down

Expected results:
host should go non-operational

Additional info:
Comment 1 Simon Grinberg 2012-10-18 07:45:48 EDT
This is not a real life case, so I would prefer to refrain placing resources to support it.

The interesting use case is if the Interfaces where the network is attached to is set is down due to loss of connectivity.

In your case - if em2 is down, will it cause status to go into non-operational?
Comment 2 Martin Pavlik 2012-10-18 08:04:41 EDT
(In reply to comment #1)
> This is not a real life case, so I would prefer to refrain placing resources
> to support it.
> 
> The interesting use case is if the Interfaces where the network is attached
> to is set is down due to loss of connectivity.
> 
> In your case - if em2 is down, will it cause status to go into
> non-operational?

Yes, host will be set as non-oprerational
Comment 3 Simon Grinberg 2012-10-21 12:36:59 EDT
Closing this, 

Not because it's not a bug, but since there is no trivial real life scenario I can think of that leads to this scenario. If anyone encounters this in non synthetic test please reopen.

Note You need to log in before you can comment on or make changes to this bug.