This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 867548 - Seam nestedbooking: jboss-jsf-api should be "provided"
Seam nestedbooking: jboss-jsf-api should be "provided"
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.1.0
Assigned To: Marek Novotny
Seam 2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 12:53 EDT by Ron Šmeral
Modified: 2016-10-31 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Šmeral 2012-10-17 12:53:47 EDT
Description of problem:
The nestedbooking example is broken, because jboss-jsf-api is currently pulled in to the WAR as a compile-scope transitive dependency of richfaces-components-ui. This breaks certain functionality. 
Most likely the "jboss-jsf-api_2.1_spec" should be declared in nestedbooking-web/pom.xml explicitly as "provided".

Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1

Steps to Reproduce:
1. Download and unpack jboss-wfk-2.1.0.ER2-seam23-demo.zip
2. Build and deploy the nestedbooking example
3. Login as gavin/foobar, search for a hotel, View Hotel > Book Hotel > Select Room, then try to click Select on any of the rooms.
  
Actual results:
A javascript error "mojarra is not defined" appears in browser.

Expected results:
Navigation to the Payment page.
Comment 3 Karel Piwko 2012-11-30 10:34:23 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.