Bug 867574 - RFE: add support for dhcpv6
RFE: add support for dhcpv6
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 14:49 EDT by Gene Czarcinski
Modified: 2015-03-18 03:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-18 03:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2012-10-17 14:49:02 EDT
Description of problem:
While libvirt currently (0.10.2) supports a limited for of IPv6 which can be used to go from a virtual guest to the virtualization host and even beyond with the correct routing specified, the only way to setup a virtual guest so that it can be accessed from another system is to use manual configuration.  What is needed is real dhcpv6 support and this can "now" be provided by dnsmasq.

Up until recently, it was not possible to use dnsmasq as a dhcpv6 server because of two problems:

1. multiple dnsmasq dhcpv6 servers could not run (would fail at startup).

2. Unless --interface was specified, dhcpv6 would not recognize legitimate dhcpv6 requests.

Both of this problems are now fixed and will be part of dnsmasq-2.64.  Patches are available for dnsmasq-2.63.

In order to support dhcpv6, it must be possible to specify a -dhcp-range for IPv6 addresses.  Specifying --listen-address and/or --interface are irrelevant.  Dnsmasq uses the IPv6 subnet specification in --dhcp-range to filter dhcpv8 packets sent to address ff00::1:2.  If the interface device supports an IPv6 subnetwork specified for support, then the requests are serviced.
Comment 1 Ján Tomko 2015-03-18 03:21:49 EDT
commit 2d5cd1d724084d9975b2514fb31776627acbe997
Author:     Gene Czarcinski <gene@czarc.net>
AuthorDate: 2012-12-06 12:20:38 -0500
Commit:     Laine Stump <laine@laine.org>
CommitDate: 2012-12-11 05:49:45 -0500

    network: add support for DHCPv6
    
    The DHCPv6 support includes IPV6 dhcp-range and dhcp-host for one
    IPv6 subnetwork on one interface.  This support will only work
    if dnsmasq version >= 2.64; otherwise an error occurs if
    dhcp-range or dhcp-host is specified for an IPv6 address.
    
    Essentially, this change provides the same DHCP support for IPv6
    that has been available for IPv4.
    
    With dnsmasq >= 2.64, support for the RA service is also now provided
    by dnsmasq (radvd is no longer used/started). (Although at least one
    version of dnsmasq prior to 2.64 "supported" IPv6 Router
    Advertisement, there were bugs (fixed in 2.64) that rendered it
    unusable.)
    
    Documentation and the network schema has been updated
    to reflect the new support.

git describe: v1.0.0-286-g2d5cd1d contains: v1.0.1-rc1~31

Note You need to log in before you can comment on or make changes to this bug.