Bug 867577 - Errata search is broken in the CLI
Errata search is broken in the CLI
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 41
Assigned To: Jay Dobies
Preethi Thomas
:
: 850905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 15:01 EDT by Jay Dobies
Modified: 2013-01-07 09:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 09:09:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2012-10-17 15:01:54 EDT
I think it was when the association metadata was removed from the output, but the errata calls that used to do those steps started to break with the following exception:

2012-10-17 14:56:18,930 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/home/jdob/code/pulp/pulp/platform/src/pulp/client/extensions/core.py", line 478, in run
    exit_code = Cli.run(self, args)
  File "/home/jdob/vault/code/okaara/src/okaara/cli.py", line 920, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/home/jdob/code/pulp/pulp/platform/src/pulp/client/extensions/extensions.py", line 224, in execute
    return self.method(*arg_list, **clean_kwargs)
  File "/home/jdob/code/pulp/pulp_rpm/pulp_rpm/src/pulp_rpm/extension/admin/contents.py", line 268, in errata
    _content_command(self.context, [TYPE_ERRATUM], self.write_erratum_detail, **new_kwargs)
  File "/home/jdob/code/pulp/pulp_rpm/pulp_rpm/src/pulp_rpm/extension/admin/contents.py", line 363, in _content_command
    out_func(units)
  File "/home/jdob/code/pulp/pulp_rpm/pulp_rpm/src/pulp_rpm/extension/admin/contents.py", line 279, in write_erratum_detail
    erratum_meta = erratum['metadata']
KeyError: 'metadata'
Comment 1 Jay Dobies 2012-10-18 08:58:45 EDT
*** Bug 850905 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Ortel 2012-10-22 11:51:56 EDT
build: 0.333
Comment 3 Preethi Thomas 2012-10-23 14:20:33 EDT
verified
[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.333-1.fc17.noarch

[root@pulp-master ~]# pulp-admin rpm repo content errata --repo-id zoo
Description:      Bear_Erratum
From Str:         errata@redhat.com
Id:               RHEA-2012:0001
Issued:           2012-01-27 16:08:05
Pkglist:          
  Name:     1
  Packages: 
    Arch:     noarch
    Epoch:    None
    Filename: bear-4.1-1.noarch.rpm
    Name:     bear
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  4.1
  Short:    
Pushcount:        1
Reboot Suggested: False
References:       
Release:          1
Rights:           
Severity:         
Solution:         
Status:           stable
Summary:          
Title:            Bear_Erratum
Type:             security
Updated:          
Version:          1

Description:      Sea_Erratum
From Str:         errata@redhat.com
Id:               RHEA-2012:0002
Issued:           2012-01-27 16:08:06
Pkglist:          
  Name:     1
  Packages: 
    Arch:     noarch
    Epoch:    None
    Filename: walrus-0.71-1.noarch.rpm
    Name:     walrus
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.71
    Arch:     noarch
    Epoch:    None
    Filename: penguin-0.9.1-1.noarch.rpm
    Name:     penguin
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.9.1
    Arch:     noarch
    Epoch:    None
    Filename: shark-0.1-1.noarch.rpm
    Name:     shark
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.1
  Short:    
Pushcount:        1
Reboot Suggested: False
References:       
Release:          1
Rights:           
Severity:         
Solution:         
Status:           stable
Summary:          
Title:            Sea_Erratum
Type:             security
Updated:          
Version:          1

Description:      Bird_Erratum
From Str:         errata@redhat.com
Id:               RHEA-2012:0003
Issued:           2012-01-27 16:08:08
Pkglist:          
  Name:     1
  Packages: 
    Arch:     noarch
    Epoch:    None
    Filename: crow-0.8-1.noarch.rpm
    Name:     crow
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.8
    Arch:     noarch
    Epoch:    None
    Filename: stork-0.12-2.noarch.rpm
    Name:     stork
    Release:  2
    Src:      http://www.fedoraproject.org
    Version:  0.12
    Arch:     noarch
    Epoch:    None
    Filename: duck-0.6-1.noarch.rpm
    Name:     duck
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.6
  Short:    
Pushcount:        1
Reboot Suggested: False
References:       
Release:          1
Rights:           
Severity:         
Solution:         
Status:           stable
Summary:          
Title:            Bird_Erratum
Type:             security
Updated:          
Version:          1

Description:      Gorilla_Erratum
From Str:         errata@redhat.com
Id:               RHEA-2012:0004
Issued:           2012-01-27 16:08:09
Pkglist:          
  Name:     1
  Packages: 
    Arch:     noarch
    Epoch:    None
    Filename: gorilla-0.62-1.noarch.rpm
    Name:     gorilla
    Release:  1
    Src:      http://www.fedoraproject.org
    Version:  0.62
  Short:    
Pushcount:        1
Reboot Suggested: False
References:       
Release:          1
Rights:           
Severity:         
Solution:         
Status:           stable
Summary:          
Title:            Gorilla_Erratum
Type:             security
Updated:          
Version:          1


[root@pulp-master ~]#
Comment 4 Preethi Thomas 2013-01-07 09:09:41 EST
Pulp 2.0 released.

Note You need to log in before you can comment on or make changes to this bug.