Bug 867775 - Sometimes can't access app any more after update domain
Sometimes can't access app any more after update domain
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 05:31 EDT by Rony Gong
Modified: 2015-05-14 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
development.log (33.06 KB, text/plain)
2012-10-18 05:31 EDT, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2012-10-18 05:31:05 EDT
Created attachment 629264 [details]
development.log

Description of problem:
Sometimes if use one account create some apps(consumed gears >15), and it contains non_scalable and scalable app, then update this domain to new domain, show exception.  after update domain, all apps can't work fine. 
If accesss thew new app url(by rhc domain show after update) , it  will be redirected to this url: 
https://jbosstest-qgong8.dev.rhcloud.com/app  (still use old domain name)


Version-Release number of selected component (if applicable):
devenv_2341

How reproducible:
Sometimes

Steps to Reproduce:
1.Create lots of apps(consumed gears >15), include all kinds of db and scalable, non_scalable app
2.Update domain
$ rhc domain update qgong8 qgong9

  
Actual results:
[qgong@localhost mv_testing]$ rhc domain update qgong8 qgong9
Password: 

Changing namespace 'qgong8' to 'qgong9'...
undefined method `debugIO' for nil:NilClass


Expected results:
1.show time out error, but app still could be used by old domain name.

Additional info:
Comment 1 Rony Gong 2012-10-18 05:32:49 EDT
For preference,all of my apps
jbosstest @ http://jbosstest-qgong8.dev.rhcloud.com/
====================================================
Created: 3:27 AM
   UUID: 9dc3a56eac7046a5b12daf62b97a750a
Git URL: ssh://9dc3a56eac7046a5b12daf62b97a750a@jbosstest-qgong8.dev.rhcloud.com/~/git/jbosstest.git/
SSH URL: ssh://9dc3a56eac7046a5b12daf62b97a750a@jbosstest-qgong8.dev.rhcloud.com

Cartridges:
  jbossas-7
  haproxy-1.4
  mysql-5.1 - mysql://4008771020-qgong8.dev.rhcloud.com:38196/


jbosseaptest @ http://jbosseaptest-qgong8.dev.rhcloud.com/
==========================================================
Created: 3:31 AM
   UUID: 055635ef67bc4757accc8df890b3aa82
Git URL: ssh://055635ef67bc4757accc8df890b3aa82@jbosseaptest-qgong8.dev.rhcloud.com/~/git/jbosseaptest.git/
SSH URL: ssh://055635ef67bc4757accc8df890b3aa82@jbosseaptest-qgong8.dev.rhcloud.com

Cartridges:
  jbosseap-6.0
  jenkins-client-1.4 - https://jenkins-qgong8.dev.rhcloud.com/job/jbosseaptest-build/
  haproxy-1.4
  mysql-5.1 - mysql://955d7cc3b0-qgong8.dev.rhcloud.com:38216/


jenkins @ http://jenkins-qgong8.dev.rhcloud.com/
================================================
Created: 3:33 AM
   UUID: 04f4d0d737d340448ee3fc434f2bdd5f
Git URL: ssh://04f4d0d737d340448ee3fc434f2bdd5f@jenkins-qgong8.dev.rhcloud.com/~/git/jenkins.git/
SSH URL: ssh://04f4d0d737d340448ee3fc434f2bdd5f@jenkins-qgong8.dev.rhcloud.com

Cartridges:
  jenkins-1.4


jbossewstest @ http://jbossewstest-qgong8.dev.rhcloud.com/
==========================================================
Created: 3:40 AM
   UUID: 595ce24301bf44fd9d4af27af23a9714
Git URL: ssh://595ce24301bf44fd9d4af27af23a9714@jbossewstest-qgong8.dev.rhcloud.com/~/git/jbossewstest.git/
SSH URL: ssh://595ce24301bf44fd9d4af27af23a9714@jbossewstest-qgong8.dev.rhcloud.com

Cartridges:
  jbossews-1.0
  jenkins-client-1.4 - https://jenkins-qgong8.dev.rhcloud.com/job/jbossewstest-build/
  haproxy-1.4
  mongodb-2.2 - mongodb://8b7e4b565f-qgong8.dev.rhcloud.com:38336/


reviewboard @ http://reviewboard-qgong8.dev.rhcloud.com/
========================================================
Created: 3:45 AM
   UUID: 6a2df6be34a44b1cbffaf81fc6dc0732
Git URL: ssh://6a2df6be34a44b1cbffaf81fc6dc0732@reviewboard-qgong8.dev.rhcloud.com/~/git/reviewboard.git/
SSH URL: ssh://6a2df6be34a44b1cbffaf81fc6dc0732@reviewboard-qgong8.dev.rhcloud.com

Cartridges:
  python-2.6
  mongodb-2.2 - mongodb://348d6d22e9-qgong8.dev.rhcloud.com:38251/
  haproxy-1.4


mediawiki @ http://mediawiki-qgong8.dev.rhcloud.com/
====================================================
Created: 3:47 AM
   UUID: 11677aef1ff34db8873888e4cd9b049d
Git URL: ssh://11677aef1ff34db8873888e4cd9b049d@mediawiki-qgong8.dev.rhcloud.com/~/git/mediawiki.git/
SSH URL: ssh://11677aef1ff34db8873888e4cd9b049d@mediawiki-qgong8.dev.rhcloud.com

Cartridges:
  php-5.3
  haproxy-1.4
  mysql-5.1 - mysql://a854a6697d-qgong8.dev.rhcloud.com:38266/


dancer @ http://dancer-qgong8.dev.rhcloud.com/
==============================================
Created: 3:49 AM
   UUID: ef520f5d40d844f3bcab7cb1617ba6ca
Git URL: ssh://ef520f5d40d844f3bcab7cb1617ba6ca@dancer-qgong8.dev.rhcloud.com/~/git/dancer.git/
SSH URL: ssh://ef520f5d40d844f3bcab7cb1617ba6ca@dancer-qgong8.dev.rhcloud.com

Cartridges:
  perl-5.10
  haproxy-1.4


railsapp @ http://railsapp-qgong8.dev.rhcloud.com/
==================================================
Created: 3:55 AM
   UUID: 25ac7a18cb484e258932ad283eee8c3c
Git URL: ssh://25ac7a18cb484e258932ad283eee8c3c@railsapp-qgong8.dev.rhcloud.com/~/git/railsapp.git/
SSH URL: ssh://25ac7a18cb484e258932ad283eee8c3c@railsapp-qgong8.dev.rhcloud.com

Cartridges:
  ruby-1.9
  haproxy-1.4
  mysql-5.1 - mysql://ba65c53d7c-qgong8.dev.rhcloud.com:38306/


qphp @ http://qphp-qgong8.dev.rhcloud.com/
==========================================
Created: 4:31 AM
   UUID: 4f4ceff2b8a6488daa3ef19946fa56f5
Git URL: ssh://4f4ceff2b8a6488daa3ef19946fa56f5@qphp-qgong8.dev.rhcloud.com/~/git/qphp.git/
SSH URL: ssh://4f4ceff2b8a6488daa3ef19946fa56f5@qphp-qgong8.dev.rhcloud.com

Cartridges:
  php-5.3
  cron-1.4
Comment 3 Xiaoli Tian 2012-10-19 01:27:51 EDT
(In reply to comment #2)
> https://github.com/openshift/origin-server/pull/718

Above pull request is merged in master since devenv_2349, move it to ON_QA for verifying.
Comment 4 Peter Ruan 2012-10-19 15:07:06 EDT
verified with AMI: devenv_2352

create apps with various flavors (scaleable and non-scaleble).

do rhc domain update pr1 pr2 -pvostok08 -d

can access apps created earlier w/o problem.

Note You need to log in before you can comment on or make changes to this bug.