This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 867784 - [RHEV-H 6.4] The "DHCP" was marked "*" in network detail page if configured nic by using "static"
[RHEV-H 6.4] The "DHCP" was marked "*" in network detail page if configured n...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks: 858651
  Show dependency treegraph
 
Reported: 2012-10-18 05:52 EDT by haiyang,dong
Modified: 2013-02-28 11:40 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Setting a static protocol for a network on the TUI did not set the corresponding value in the configuration files, so static IP could not be set. Instead, the DHCP option would override the provided IP. Now, the static IP configuration information is correctly set in /etc/defaults/ovirt, so configuring a static IP succeeds.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:40:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
attached the ifcfg-* file (315 bytes, application/x-gzip)
2012-10-18 05:52 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-10-18 05:52:27 EDT
Created attachment 629283 [details]
attached the ifcfg-* file

Description of problem:
At first, configure network by using "Static" Protocol with correct ip address/netmask/gateway ,
then,the network can be configured success, but the network detail page displays that "DHCP" is marked "*" instead of "Static".

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.4-20121015.1.el6.
2. Configure network.
3. Enter network detail page and configure network by using "static" with correct ip address/netmask/gateway
4. After configured nic success,focus on Network detail page.

Actual results:
the network detail page displays that "DHCP" is marked "*" instead of "Static"

Expected results:
The "Static" should be marked "*" to show the network configured if used "Static" Protocol with correct ip address/netmask/gateway

Additional info:
--
Comment 2 haiyang,dong 2012-10-19 06:08:03 EDT
No this issue on the build 6.3.z, so it's a regression from 6.3 to 6.4,add "Regression" into Keywords.
Comment 6 Fabian Deutsch 2012-10-19 07:02:49 EDT
http://gerrit.ovirt.org/8673

Tested as follows:
1. Set to static ip (10.0.0.1/24 + .2 as gw) hit apply
2. Re-enter nic details page: static is checked, defaults/ovirt contains entry and ifcfg-* are configured properly

3. Set to dhcp and hit apply
4. Re-enter nic details page: dhcp is checked, ip addresse are from dhcp and ro, defaults/ovirt doesn't contain address anymore, ifcfg-* contain dhcp
Comment 8 haiyang,dong 2012-12-13 04:02:55 EST
Test version:
rhev-hypervisor6-6.4-20121206.0.el6
ovirt-node-2.5.0-10.el6

Tested as follows:
1. Install rhev-h
2. Configure network.
3. Enter network detail page and configure network by using "static" with correct ip address/netmask/gateway
4. After configured nic success,focus on Network detail page:
static is checked, defaults/ovirt contains entry and ifcfg-* are configured properly
5. Set to dhcp and hit apply
6. Re-enter nic details page: dhcp is checked, ip addresse are from dhcp and ro, defaults/ovirt doesn't contain address anymore, ifcfg-* contain dhcp

also tried the same steps with vlanid , couldn't reproduce this bug,
so this bug has been fixed,change the status into "VERIFIED"
Comment 9 haiyang,dong 2012-12-26 03:37:00 EST
so follow steps of comment 8 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 11 errata-xmlrpc 2013-02-28 11:40:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.