Bug 867789 - QutIM 0.3 doesn't connect to the jabber in F18
QutIM 0.3 doesn't connect to the jabber in F18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qutim (Show other bugs)
18
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 05:58 EDT by carasin
Modified: 2012-10-30 16:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 16:07:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1068034 None None None 2012-10-18 06:00:21 EDT

  None (edit)
Description carasin 2012-10-18 05:58:10 EDT
Description of problem:

QutIM doesn't connect to the jabber.
I tried to install qutim from F17 repo, but the situation is the same.
Anyway the same qutim build (*.fc17.rpm) works fine in Fedora 17.
Else: other jabber clients (Telepathy, etc.) work fine in Fedora 18.
___________________________________

Version-Release number of selected component (if applicable):

Fedora 18 (in development, up to date)
qutim-0.3.1-2.fc18.i686
qutim-0.3.1-1.fc17.i686
___________________________________

How reproducible:

Allways.
___________________________________

Steps to Reproduce:
1. launch QutIM;
2. create the jabber account, type login / password;
3. try to connect to the jabber service.
___________________________________

Actual results:

QutIM doesn't connect to the jabber.
___________________________________

Expected results:

QutIM connects to the jabber.
___________________________________

Additional info:
Comment 1 Vasiliy Glazov 2012-10-18 06:03:17 EDT
I can confirm problem.
Comment 2 Pavel Alexeev 2012-10-18 07:40:59 EDT
Hello and thanks for the bugreport and willing make free software better!


>I tried to install qutim from F17 repo, but the situation is the same.
>Anyway the same qutim build (*.fc17.rpm) works fine in Fedora 17.

>Version-Release number of selected component (if applicable):

>Fedora 18 (in development, up to date)
>qutim-0.3.1-2.fc18.i686
?qutim-0.3.1-1.fc17.i686

I can't understand what exactly version of Fedora and qutim are you using?
Comment 3 carasin 2012-10-18 10:20:39 EDT
I use F18.
First qutim-0.3.1-2.fc18.i686 was used (but the bug appeared).
I decided to downgrade to qutim-0.3.1-1.fc17.i686 (because this version worked fine in F17) with help of <--releasever=17> yum option. But the bug has not disappeared.
Now I came back to qutim-0.3.1-2.fc18.i686.
Comment 4 carasin 2012-10-20 14:01:14 EDT
Is there any progress?
Comment 5 Pavel Alexeev 2012-10-21 08:54:09 EDT
Please check that rawhide build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4612526
Comment 6 carasin 2012-10-22 04:47:56 EDT
(In reply to comment #5)
> Please check that rawhide build:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4612526

Well! It works!
YUM told to install the dependencies: <qca-cyrus-sasl> and <qca-gnupg> packages. Now <qutim-0.3.1-3.fc19.i686> is installed and jabber works fine.
Comment 7 carasin 2012-10-22 04:50:18 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > Please check that rawhide build:
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=4612526
> 
> Well! It works!
> YUM told to install the dependencies: <qca-cyrus-sasl> and <qca-gnupg>
> packages. Now <qutim-0.3.1-3.fc19.i686> is installed and jabber works fine.

After this I've executed <# yum distro-sync>, the QutIM version came back to <qutim-0.3.1-2.fc18.i686>, and it works too. It seems, there are broken dependencies because with installed <qca-cyrus-sasl> and <qca-gnupg> QitIM works fine with jabber.
Comment 8 Vasiliy Glazov 2012-10-30 14:06:08 EDT
I think bug may be closed.
Comment 9 Pavel Alexeev 2012-10-30 16:07:46 EDT
Yes it is. It was missing dependencies.

Note You need to log in before you can comment on or make changes to this bug.