Bug 867811 - [xfs/xfstests 113] aiostress kernel hang
[xfs/xfstests 113] aiostress kernel hang
Status: CLOSED DUPLICATE of bug 867277
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Dave Chinner
Red Hat Kernel QE team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 06:43 EDT by Boris Ranto
Modified: 2012-10-23 17:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 17:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The kernel messages on hang (362.14 KB, text/plain)
2012-10-18 06:43 EDT, Boris Ranto
no flags Details

  None (edit)
Description Boris Ranto 2012-10-18 06:43:37 EDT
Created attachment 629310 [details]
The kernel messages on hang

Description of problem:
The test no. 113 from xfstests test suite causes kernel hang.

Version-Release number of selected component (if applicable):
kernel-2.6.32-328.el6

How reproducible:
Always

Steps to Reproduce:
1. Run the test
cd /mnt/tests/kernel/filesystems/xfs/xfstests
./install_all.sh # This just installs the dependencies, no need to run it if they're already installed
TEST_PARAM_RUNTESTS=113 make
  
Actual results:
The kernel (and test) hangs.

Expected results:
No hang, the test passes.

Additional info:
I'm attaching the kernel messages (the hung-task-timeout messages + sysrq t output).
This seems to be a regression that occurrs on kernels with the big 6.4 patchset.
Comment 2 Dave Chinner 2012-10-23 17:12:03 EDT

*** This bug has been marked as a duplicate of bug 867277 ***

Note You need to log in before you can comment on or make changes to this bug.