Bug 867855 - [RHEL5] pcp - python-ctypes dependency missing
[RHEL5] pcp - python-ctypes dependency missing
Status: CLOSED CANTFIX
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: pcp (Show other bugs)
DTS 1.1 RHEL 5
All Linux
unspecified Severity medium
: beta2
: 1.1
Assigned To: Nathan Scott
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 08:33 EDT by Tomas Dohnalek
Modified: 2013-02-15 02:30 EST (History)
7 users (show)

See Also:
Fixed In Version: devtoolset-1.1-pcp-3.6.9-2.el[56]
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 10:36:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dohnalek 2012-10-18 08:33:01 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build Identifier: 

When running new upstream test-suite's test-case 710 on RHEL5, there are python import errors for ctypes module.

Reproducible: Always

Steps to Reproduce:
1. run pcp-testsuite test-case 710 or 708
Actual Results:  
[root@x86-64-v05 testsuite]# python /opt/rh/devtoolset-1.1/root/var/lib/pcp/testsuite/src/check_import.python /tmp/13114.pcplog
	Traceback (most recent call last):
	  File "/opt/rh/devtoolset-1.1/root/var/lib/pcp/testsuite/src/check_import.python", line 19, in ?
	    from pcp import *
	  File "/opt/rh/devtoolset-1.1/root/usr/lib64/python2.4/site-packages/pcp.py", line 83, in ?
	    import ctypes
	ImportError: No module named ctypes
Comment 1 Frank Ch. Eigler 2012-10-18 08:35:20 EDT
Adding a Requires: python-ctypes to the spec will cure this, both on rhel5 and rhel6 (where python-ctypes is a virtual provide by core python).
Comment 2 Nathan Scott 2012-10-18 19:58:47 EDT
Frank's fix has been merged into the upstream PCP git tree.

Note You need to log in before you can comment on or make changes to this bug.