Bug 868022 - Inconsistent section descriptions in pulp-admin client
Inconsistent section descriptions in pulp-admin client
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 18:16 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 11:59:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2012-10-18 18:16:48 EDT
Description of problem:


We have a really inconsistent way of section descriptions in pulp-admin. While it is very low priority, we should clean it up and come up with a standard way for section descriptions. Some examples - 

consumer - consumer lifecycle (list, update, etc.) commands
event    - manage server-side events
puppet   - contains commands for working with Puppet repositories
tasks    - list and cancel tasks running in the Pulp server
Comment 1 Jeff Ortel 2012-11-12 17:33:31 EST
build: 2.0.6-0.2.beta
Comment 2 Preethi Thomas 2012-11-26 20:43:05 EST
This still seem to be inconsistent. Failing

[root@preethi ~]# rpm -q pulp-server
pulp-server-2.0.6-0.9.beta.noarch


[root@preethi ~]# pulp-admin
Usage: pulp-admin [SECTION, ..] COMMAND

Available Sections:
  auth     - user, role and permission commands
  bindings - search bindings
  event    - subscribe to event notifications
  orphan   - find and remove orphaned content units
  puppet   - manage Puppet-related content and features
  repo     - list repositories and manage repo groups
  rpm      - manage RPM-related content and features
  server   - display info about the server
  tasks    - list and cancel server-side tasks

Available Commands:
  login  - login and download a session certificate
  logout - deletes the user's session certificate
[root@preethi ~]#
Comment 3 Michael Hrivnak 2012-11-27 09:45:19 EST
Perhaps you can explain what is inconsistent, or what you'd like to see different? I think they are all short, simple, and accurate descriptions.

That said, there is a new "bindings" section that appeared since I last worked on this bug; perhaps that's the description you aren't happy with?
Comment 4 Preethi Thomas 2012-11-27 15:27:09 EST
yes bindings is what I meant primarily, Also i thought saying  "user, role and permission commands" auth  while nothing else have the word command may be reworded as well.
may be something like

auth     - manage user, role and permission
Comment 5 Jay Dobies 2012-12-07 16:16:57 EST
Moving out of 2.0, we're close enough for now.
Comment 6 Michael Hrivnak 2013-01-09 13:21:20 EST
https://github.com/pulp/pulp/pull/245
Comment 7 Jeff Ortel 2013-01-19 11:59:37 EST
build: 2.1.0-0.1.alpha
Comment 8 Preethi Thomas 2013-01-24 10:00:25 EST
verified

[root@preethi-el6-pulp ~]#  pulp-admin
Usage: pulp-admin [SUB_SECTION, ..] COMMAND

Available Sections:
  auth     - manage users, roles and permissions
  bindings - search consumer bindings
  event    - subscribe to event notifications
  orphan   - find and remove orphaned content units
  puppet   - manage Puppet-related content and features
  repo     - list repositories and manage repo groups
  rpm      - manage RPM-related content and features
  server   - display info about the server
  tasks    - list and cancel server-side tasks

Available Commands:
  login  - login and download a session certificate
  logout - deletes the user's session certificate
[root@preethi-el6-pulp ~]#
Comment 9 Preethi Thomas 2013-04-08 11:59:07 EDT
Pulp 2.1 released 


http://www.pulpproject.org/2013/04/05/pulp-2-1-0-released/

Note You need to log in before you can comment on or make changes to this bug.