This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 868063 - [abrt]: WARNING: at drivers/net/wireless/iwlwifi/iwl-io.c:150 iwl_grab_nic_access+0x75/0x150 [iwlwifi](): TAINTED GF
[abrt]: WARNING: at drivers/net/wireless/iwlwifi/iwl-io.c:150 iwl_grab_nic_ac...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:c356b97dc8cc003b74ca946f5e2...
:
: 873437 873438 874758 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 22:34 EDT by Mikhail
Modified: 2013-05-02 08:13 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-02 08:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
iwl_do_not_request_nic_access.patch (577 bytes, text/plain)
2012-10-30 05:40 EDT, Stanislaw Gruszka
no flags Details
RFkill in transport layer (9.04 KB, patch)
2012-10-30 07:30 EDT, Emmanuel Grumbach
no flags Details | Diff
dmesg output (59.54 KB, text/plain)
2012-11-05 17:08 EST, Mikhail
no flags Details
dmesg output (182.75 KB, text/plain)
2012-11-06 22:00 EST, Mikhail
no flags Details
dmesg-3.6.4-1.bz868063 output (145.66 KB, text/plain)
2012-11-07 13:31 EST, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-10-18 22:34:11 EDT
Additional info:
libreport version: 2.0.16
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.0-0.rc7.git1.4.fc18.i686 root=UUID=584dd4d0-e2a2-4990-b73b-e60c21c508ef ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 rhgb quiet LANG=en_US.UTF-8 KEYTABLE=us
kernel:         3.6.0-0.rc7.git1.4.fc18.i686

kernel_tainted_long:
:Proprietary module has not been loaded.
:Module has been forcibly loaded.
Comment 1 Stanislaw Gruszka 2012-10-23 09:50:43 EDT
This warning usually mean PCIe problems (firmware eg. BIOS or PCIe driver). How long do you use fedore on this system? If this this is first installation , could you try to update BIOS? If not, what is the latest kernel which did not trigger this problem? And, is this problem reproducible, if so provide steps to reproduce.
Comment 2 Mikhail 2012-10-25 10:19:56 EDT
Hmm I am don't see on which machine occurs this problem from my first message. I am have a lot of machines which work on Fedora 17 and some machines which already updated to F18.
Comment 3 Stanislaw Gruszka 2012-10-25 10:57:23 EDT
This is on F18. You can look for UUID=584dd4d0-e2a2-4990-b73b-e60c21c508ef to identify machine - need to run blkid command on each and compere UUID with reported here.
Comment 4 Mikhail 2012-10-25 10:59:06 EDT
On/Off wifi intel 5150 module

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 5 Mikhail 2012-10-25 11:06:22 EDT
Yeah I find this machine and reproduce problem now.

This is ASUS Eee PC 900

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:00.0 Network controller: Intel Corporation WiMAX/WiFi Link 5150
03:00.0 Ethernet controller: Atheros Communications Inc. L2 Fast Ethernet (rev a0)


$ lsusb
Bus 001 Device 002: ID 0951:1606 Kingston Technology Eee PC 701 SD Card Reader [ENE UB6225]
Bus 001 Device 006: ID 8086:0180 Intel Corp. WiMAX Connection 2400m
Bus 001 Device 004: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


And I can see that this occurs when I switch on WiFi by software key.

$ dmesg
...
[23165.377924] eeepc_laptop: Unknown key 51 pressed
[23240.647422] usb 1-6: USB disconnect, device number 5
[23242.711056] iwlwifi 0000:01:00.0: Error sending REPLY_RXON: time out after 2000ms.
[23242.711068] iwlwifi 0000:01:00.0: Current CMD queue read_ptr 73 write_ptr 76
[23242.711076] iwlwifi 0000:01:00.0: Error clearing ASSOC_MSK on BSS (-110)
[23242.712015] ------------[ cut here ]------------
[23242.712015] WARNING: at drivers/net/wireless/iwlwifi/iwl-io.c:150 iwl_grab_nic_access+0x5e/0x70 [iwlwifi]()
[23242.712015] Hardware name: 900
[23242.712015] Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
[23242.712015] Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat lockd bnep bluetooth iptable_mangle nf_conntrack_ipv4 be2iscsi nf_defrag_ipv4 xt_conntrack iscsi_boot_sysfs nf_conntrack bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi arc4 iTCO_wdt iwldvm i2400m_usb mac80211 iTCO_vendor_support i2400m uvcvideo snd_hda_codec_realtek wimax snd_hda_intel videobuf2_vmalloc videobuf2_memops snd_hda_codec videobuf2_core videodev snd_hwdep snd_seq media snd_seq_device snd_pcm microcode joydev i2c_i801 iwlwifi snd_page_alloc lpc_ich
[23242.712015]  snd_timer cfg80211 snd soundcore eeepc_laptop sparse_keymap rfkill uinput i915(F) usb_storage(F) i2c_algo_bit(F) atl2(F) drm_kms_helper(F) drm(F) i2c_core(F) video(F) sunrpc(F)
[23242.712015] Pid: 575, comm: NetworkManager Tainted: GF            3.6.3-3.fc18.i686 #1
[23242.712015] Call Trace:
[23242.712015]  [<c043c562>] warn_slowpath_common+0x72/0xa0
[23242.712015]  [<f7d282ae>] ? iwl_grab_nic_access+0x5e/0x70 [iwlwifi]
[23242.712015]  [<f7d282ae>] ? iwl_grab_nic_access+0x5e/0x70 [iwlwifi]
[23242.712015]  [<c043c633>] warn_slowpath_fmt+0x33/0x40
[23242.712015]  [<f7d282ae>] iwl_grab_nic_access+0x5e/0x70 [iwlwifi]
[23242.712015]  [<f7d28440>] iwl_write_prph+0x30/0x80 [iwlwifi]
[23242.712015]  [<f7d31168>] iwl_trans_pcie_stop_device+0x1e8/0x310 [iwlwifi]
[23242.712015]  [<f814b9b1>] iwl_down+0x1d1/0x280 [iwldvm]
[23242.712015]  [<f8152a06>] iwlagn_mac_stop+0x66/0xd0 [iwldvm]
[23242.712015]  [<f8222206>] ieee80211_stop_device+0x46/0xe0 [mac80211]
[23242.712015]  [<f820f7c0>] ieee80211_do_stop+0x260/0x600 [mac80211]
[23242.712015]  [<c0959af3>] ? _raw_spin_unlock_bh+0x13/0x20
[23242.712015]  [<c0883c07>] ? dev_deactivate_many+0x187/0x1d0
[23242.712015]  [<f820fb77>] ieee80211_stop+0x17/0x20 [mac80211]
[23242.712015]  [<c08667c9>] __dev_close_many+0x69/0xb0
[23242.712015]  [<c086683d>] __dev_close+0x2d/0x50
[23242.712015]  [<c086bd21>] __dev_change_flags+0x81/0x160
[23242.712015]  [<c086bea1>] dev_change_flags+0x21/0x60
[23242.712015]  [<c08767dd>] do_setlink+0x2bd/0x880
[23242.712015]  [<c0878ad0>] ? rtnl_configure_link+0xa0/0xa0
[23242.712015]  [<c0684fc2>] ? nla_parse+0x22/0xa0
[23242.712015]  [<c0878e4e>] rtnl_newlink+0x37e/0x550
[23242.712015]  [<c0618e92>] ? selinux_capable+0x32/0x40
[23242.712015]  [<c0615bcc>] ? security_capable+0x1c/0x30
[23242.712015]  [<c0447be7>] ? ns_capable+0x27/0x60
[23242.712015]  [<c0878ad0>] ? rtnl_configure_link+0xa0/0xa0
[23242.712015]  [<c08786dc>] rtnetlink_rcv_msg+0x12c/0x2b0
[23242.712015]  [<c08785b0>] ? __rtnl_unlock+0x20/0x20
[23242.712015]  [<c088d736>] netlink_rcv_skb+0x86/0xa0
[23242.712015]  [<c0875e4c>] rtnetlink_rcv+0x1c/0x30
[23242.712015]  [<c088d104>] netlink_unicast+0x164/0x1e0
[23242.712015]  [<c088d399>] netlink_sendmsg+0x219/0x370
[23242.712015]  [<c08557a4>] sock_sendmsg+0xa4/0xd0
[23242.712015]  [<c0856709>] __sys_sendmsg+0x299/0x2b0
[23242.712015]  [<c0856ad0>] ? sock_aio_write+0x110/0x110
[23242.712015]  [<c046c3c5>] ? scheduler_tick+0xd5/0x100
[23242.712015]  [<c0670bb8>] ? timerqueue_add+0x58/0xb0
[23242.712015]  [<c048747e>] ? ktime_get+0x5e/0x100
[23242.712015]  [<c042426b>] ? lapic_next_event+0x1b/0x20
[23242.712015]  [<c08579db>] sys_sendmsg+0x3b/0x60
[23242.712015]  [<c0858073>] sys_socketcall+0x273/0x2d0
[23242.712015]  [<c096065f>] sysenter_do_call+0x12/0x28
[23242.712015]  [<c0950000>] ? set_intr_gate+0x10/0x3b
[23242.712015] ---[ end trace 9ca3b2aea12bd7c5 ]---
Comment 6 Mikhail 2012-10-25 11:27:51 EDT
It's occurs when I switch off internal WiFi/WiMAX card
Comment 7 Stanislaw Gruszka 2012-10-25 15:51:43 EDT
When you switch back on radio, does the device work? Or it is not able to recover from that problem?
Comment 8 Mikhail 2012-10-25 21:54:25 EDT
(In reply to comment #7)
> When you switch back on radio, does the device work? Or it is not able to
> recover from that problem?

When I switch back on radio device is work.
Comment 9 Stanislaw Gruszka 2012-10-30 05:40:54 EDT
Created attachment 635442 [details]
iwl_do_not_request_nic_access.patch

Not sure if this is right fix, but it should prevent the warning, Emmanuel?
Comment 10 Emmanuel Grumbach 2012-10-30 05:46:41 EDT
(In reply to comment #9)
> Created attachment 635442 [details]
> iwl_do_not_request_nic_access.patch
> 
> Not sure if this is right fix, but it should prevent the warning, Emmanuel?

No this is not the right fix. If the device is enabled, then we should be able to grab_nic_access.

Ok, so just to recap:
when you KILL the radio you see that message, right?
I am now doing tests to see what happens here.
I guess DEVICE_ENABLED shouldn't be set.
One second. WIP.
Comment 11 Emmanuel Grumbach 2012-10-30 06:37:04 EDT
were there any message regarding RFKILL before the snippet you sent?
Comment 12 Emmanuel Grumbach 2012-10-30 07:11:26 EDT
Please reproduce with debug=0x00020001 and send all the dmesg output.
Thanks
Comment 13 Stanislaw Gruszka 2012-10-30 07:22:27 EDT
Mikhail, plese do the following:

# echo "options iwlwifi debug=debug=0x00020001" >> /etc/modprobe.d/iwlwifi.conf

Restart the machine and reproduce the problem.

# dmesg > dmesg.txt

and provide dmesg.txt here.
Comment 14 Emmanuel Grumbach 2012-10-30 07:30:45 EDT
Created attachment 635526 [details]
RFkill in transport layer
Comment 15 Emmanuel Grumbach 2012-10-30 07:33:17 EDT
Also, please try the patch I just attached.
This is something I did before your bug report and that we haven't published yet.
It may help too.
Comment 16 Stanislaw Gruszka 2012-10-30 09:27:30 EDT
I lunched test kernel build with above patch here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4638889
Comment 17 Mikhail 2012-11-05 17:08:04 EST
(In reply to comment #13)
> Mikhail, plese do the following:
> 
> # echo "options iwlwifi debug=debug=0x00020001" >>
> /etc/modprobe.d/iwlwifi.conf
> 
> Restart the machine and reproduce the problem.
> 
> # dmesg > dmesg.txt
> 
> and provide dmesg.txt here.

I can't reproduce this problem with "options iwlwifi debug=debug=0x00020001", because if I boot computer with this option, WiFi is unavailable (available only WiMAX interface).
Comment 18 Mikhail 2012-11-05 17:08:41 EST
Created attachment 638918 [details]
dmesg output
Comment 19 Mikhail 2012-11-05 17:21:26 EST
(In reply to comment #16)
> I lunched test kernel build with above patch here:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4638889


I am couldn't try this kernel because newer kernel (kernel-3.6.5-2) already installed.

$ sudo yum install Downloads/kernel-3.6.4-1.bz868063.fc18.i686.rpm
Loaded plugins: langpacks, presto, refresh-packagekit
Examining Downloads/kernel-3.6.4-1.bz868063.fc18.i686.rpm: kernel-3.6.4-1.bz868063.fc18.i686
Marking Downloads/kernel-3.6.4-1.bz868063.fc18.i686.rpm to be installed
Marking Downloads/kernel-3.6.4-1.bz868063.fc18.i686.rpm as an update to kernel-3.6.0-0.rc2.git2.1.fc18.i686
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:3.6.4-1.bz868063.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package Arch  Version                Repository                           Size
================================================================================
Installing:
 kernel  i686  3.6.4-1.bz868063.fc18  /kernel-3.6.4-1.bz868063.fc18.i686   89 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 89 M
Installed size: 89 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  package kernel-3.6.5-2.fc18.i686 (which is newer than kernel-3.6.4-1.bz868063.fc18.i686) is already installed
Comment 20 Emmanuel Grumbach 2012-11-06 01:36:57 EST
(In reply to comment #17)
> (In reply to comment #13)
> > Mikhail, plese do the following:
> > 
> > # echo "options iwlwifi debug=debug=0x00020001" >>
> > /etc/modprobe.d/iwlwifi.conf
> > 
> > Restart the machine and reproduce the problem.
> > 
> > # dmesg > dmesg.txt
> > 
> > and provide dmesg.txt here.
> 
> I can't reproduce this problem with "options iwlwifi
> debug=debug=0x00020001", because if I boot computer with this option, WiFi
> is unavailable (available only WiMAX interface).

There was a typo here and it should be:
# echo "options iwlwifi debug=0x00020001" >>/etc/modprobe.d/iwlwifi.conf
Also please make sure to remove the previous (buggy) line you added.
Comment 21 Stanislaw Gruszka 2012-11-06 03:38:20 EST
(In reply to comment #19)
> $ sudo yum install Downloads/kernel-3.6.4-1.bz868063.fc18.i686.rpm
[snip]
> I am couldn't try this kernel because newer kernel (kernel-3.6.5-2) already
> installed.

You can install it by do "rpm -ivh --force kernel.rpm". If that will not work, there will be other rpm option that will ignore the version. 

(In reply to comment #20)
> There was a typo here and it should be:
> # echo "options iwlwifi debug=0x00020001" >>/etc/modprobe.d/iwlwifi.conf
> Also please make sure to remove the previous (buggy) line you added.

Yes, sorry my fault. Just override this file by: 
# echo "options iwlwifi debug=0x00020001" > /etc/modprobe.d/iwlwifi.conf
Comment 22 Stanislaw Gruszka 2012-11-06 03:44:18 EST
*** Bug 873437 has been marked as a duplicate of this bug. ***
Comment 23 Mikhail 2012-11-06 22:00:49 EST
Created attachment 639768 [details]
dmesg output
Comment 24 Mikhail 2012-11-07 13:29:33 EST
(In reply to comment #21)
> You can install it by do "rpm -ivh --force kernel.rpm". If that will not
> work, there will be other rpm option that will ignore the version. 

I am trying attached kernel and it not solve this problem.
I am also attached dmesg output here.
Comment 25 Mikhail 2012-11-07 13:31:08 EST
Created attachment 640262 [details]
dmesg-3.6.4-1.bz868063 output
Comment 26 Emmanuel Grumbach 2012-11-07 16:00:52 EST
I can see that you see this message only when you unload the module.
This is bug - no doubt about it. I just want to make sure that this is the issue you are reporting and not something else.
Comment 27 Emmanuel Grumbach 2012-11-07 16:08:04 EST
and please note that the log you sent is different from the first:
no failures in command sending:

[23242.711056] iwlwifi 0000:01:00.0: Error sending REPLY_RXON: time out after 2000ms.
[23242.711068] iwlwifi 0000:01:00.0: Current CMD queue read_ptr 73 write_ptr 76
Comment 28 Josh Boyer 2012-11-08 15:37:45 EST
*** Bug 874758 has been marked as a duplicate of this bug. ***
Comment 29 Mikhail 2012-11-24 03:10:46 EST
Occurs when I switch off WiFi

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 30 Mikhail 2012-11-24 03:19:39 EST
This problem still occurs with 3.6.7-5 kernel
Comment 31 Mikhail 2012-12-09 09:34:29 EST
Problem still exists in 3.6.9-4 kernel
Comment 32 Stanislaw Gruszka 2013-01-07 03:19:43 EST
We have dmesg of patched kernel with debugging enabled in comment 35. Emmanuel, does any other information has to be provided here to proceed this bug?
Comment 33 Stanislaw Gruszka 2013-01-07 03:23:24 EST
*** Bug 873438 has been marked as a duplicate of this bug. ***
Comment 34 Emmanuel Grumbach 2013-01-07 04:09:45 EST
can you please try again with power save disabled?

power_save=0
Comment 35 Stanislaw Gruszka 2013-01-24 08:40:50 EST
Mikhail, does module option power_save=0 workaround this issue ?
Comment 36 Mikhail 2013-01-26 05:05:52 EST
switch radio off/on

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 37 Stanislaw Gruszka 2013-01-28 06:23:25 EST
Mikhail, does above comment mean that power_save=0 did not prevent the problem ?
Comment 38 Emmanuel Grumbach 2013-02-06 03:00:08 EST
So I just saw this internally. It seems that taking the NIC out and putting it back in helped. Bad contact?
Comment 39 Stanislaw Gruszka 2013-02-06 09:38:14 EST
In this case this WARNING is triggered when RFKILL switch is on (radio off) and device enables correctly after RFKILL off. So this seems to not be a pure contact problem. However it still could be HW issue. I'm not sure how RFKILL exactly works, but I think there is RFKILL PCIE signal which is asserted when switch is turned on and that handled by device firmware. Looks on this case except assert the signal, laptop hardware also disable the wifi device at all.
Comment 40 Stanislaw Gruszka 2013-05-02 08:13:37 EDT
I'm not sure what can we do here? Probably nothing - I'm closing with "will not fix" resolution.

Note You need to log in before you can comment on or make changes to this bug.